summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-05-29 14:23:41 +0000
committerAli Polatel <hawking@gentoo.org>2008-05-29 14:23:41 +0000
commitbc5a0232556b8d67b501f23636faddd0b0e0185f (patch)
tree733e56a04368183e06f2f5a00458086ae28f23ea /dev-python
parentstable x86, bug 222519 (diff)
downloadgentoo-2-bc5a0232556b8d67b501f23636faddd0b0e0185f.tar.gz
gentoo-2-bc5a0232556b8d67b501f23636faddd0b0e0185f.tar.bz2
gentoo-2-bc5a0232556b8d67b501f23636faddd0b0e0185f.zip
python_mod_compile is ROOT aware.
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygobject/ChangeLog6
-rw-r--r--dev-python/pygobject/pygobject-2.14.0.ebuild4
-rw-r--r--dev-python/pygobject/pygobject-2.14.1.ebuild4
-rw-r--r--dev-python/pygobject/pygobject-2.14.2.ebuild4
4 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index cb76ae1d4fc9..4fa46fff1d9b 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.38 2008/05/25 21:19:59 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.39 2008/05/29 14:23:41 hawking Exp $
+
+ 29 May 2008; Ali Polatel <hawking@gentoo.org> pygobject-2.14.0.ebuild,
+ pygobject-2.14.1.ebuild, pygobject-2.14.2.ebuild:
+ python_mod_compile is ROOT aware.
25 May 2008; Gilles Dartiguelongue <eva@gentoo.org>
pygobject-2.12.3.ebuild:
diff --git a/dev-python/pygobject/pygobject-2.14.0.ebuild b/dev-python/pygobject/pygobject-2.14.0.ebuild
index a7d08e25f927..4e05fc7eb678 100644
--- a/dev-python/pygobject/pygobject-2.14.0.ebuild
+++ b/dev-python/pygobject/pygobject-2.14.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.0.ebuild,v 1.10 2008/01/10 09:37:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.0.ebuild,v 1.11 2008/05/29 14:23:41 hawking Exp $
WANT_AUTOCONF=none
WANT_AUTOMAKE=1.8
@@ -66,7 +66,7 @@ pkg_postinst() {
python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
- python_mod_compile "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
+ python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
}
pkg_postrm() {
diff --git a/dev-python/pygobject/pygobject-2.14.1.ebuild b/dev-python/pygobject/pygobject-2.14.1.ebuild
index 95ed635f594e..fa89ccc04d40 100644
--- a/dev-python/pygobject/pygobject-2.14.1.ebuild
+++ b/dev-python/pygobject/pygobject-2.14.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.1.ebuild,v 1.7 2008/03/22 03:49:36 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.1.ebuild,v 1.8 2008/05/29 14:23:41 hawking Exp $
WANT_AUTOMAKE=1.9.6
inherit gnome2 python autotools
@@ -71,7 +71,7 @@ pkg_postinst() {
python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
- python_mod_compile "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
+ python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
}
pkg_postrm() {
diff --git a/dev-python/pygobject/pygobject-2.14.2.ebuild b/dev-python/pygobject/pygobject-2.14.2.ebuild
index 2ede2d5f45da..69093f40f4a8 100644
--- a/dev-python/pygobject/pygobject-2.14.2.ebuild
+++ b/dev-python/pygobject/pygobject-2.14.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.2.ebuild,v 1.1 2008/05/25 21:19:59 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.2.ebuild,v 1.2 2008/05/29 14:23:41 hawking Exp $
inherit gnome2 python autotools
@@ -66,7 +66,7 @@ pkg_postinst() {
python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
- python_mod_compile "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
+ python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
}
pkg_postrm() {