summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-15 18:10:35 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-15 18:10:35 +0000
commitc970d3ff470d08628aab5a5b23ce6a1fe2f377a0 (patch)
tree82306d08eb2091829b1b32dc76436c209ab7e825 /dev-python
parentCleanup the stupid -r1/patching/non-default ebuilds. (diff)
downloadgentoo-2-c970d3ff470d08628aab5a5b23ce6a1fe2f377a0.tar.gz
gentoo-2-c970d3ff470d08628aab5a5b23ce6a1fe2f377a0.tar.bz2
gentoo-2-c970d3ff470d08628aab5a5b23ce6a1fe2f377a0.zip
Convert to distutils-r1.
(Portage version: 2.2.5/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hachoir-core/ChangeLog7
-rw-r--r--dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/hachoir-core/ChangeLog b/dev-python/hachoir-core/ChangeLog
index 922fea3b6e41..fc4c6e78db1b 100644
--- a/dev-python/hachoir-core/ChangeLog
+++ b/dev-python/hachoir-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/hachoir-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hachoir-core/ChangeLog,v 1.8 2013/06/16 10:15:21 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hachoir-core/ChangeLog,v 1.9 2013/09/15 18:10:35 mgorny Exp $
+
+*hachoir-core-1.3.3-r1 (15 Sep 2013)
+
+ 15 Sep 2013; Michał Górny <mgorny@gentoo.org> +hachoir-core-1.3.3-r1.ebuild:
+ Convert to distutils-r1.
16 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
python will maintain this: http://www.gossamer-
diff --git a/dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild b/dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..0f7843dc4267
--- /dev/null
+++ b/dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild,v 1.1 2013/09/15 18:10:35 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Core of Hachoir framework: parse and edit binary files"
+HOMEPAGE="http://bitbucket.org/haypo/hachoir/wiki/hachoir-core http://pypi.python.org/pypi/hachoir-core"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_configure_all() {
+ mydistutilsargs=( --setuptools )
+}
+
+python_test() {
+ "${PYTHON}" test_doc.py || die "Tests fail with ${EPYTHON}"
+}