summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-02-17 17:44:54 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-02-17 17:44:54 +0000
commitc9fdfeb65452c4b7726cae28de9e28411b0dee92 (patch)
tree8aa845837c85023570fa5d71993fb094ae1720e4 /dev-python
parentsci-geosciences/qlandkartegt: Backport patch for OSM useragent restrictions, ... (diff)
downloadgentoo-2-c9fdfeb65452c4b7726cae28de9e28411b0dee92.tar.gz
gentoo-2-c9fdfeb65452c4b7726cae28de9e28411b0dee92.tar.bz2
gentoo-2-c9fdfeb65452c4b7726cae28de9e28411b0dee92.zip
fix for a dep of a cve
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-keystoneclient/ChangeLog8
-rw-r--r--dev-python/python-keystoneclient/python-keystoneclient-0.6.0.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-python/python-keystoneclient/ChangeLog b/dev-python/python-keystoneclient/ChangeLog
index 4722a5034092..caaa2174c843 100644
--- a/dev-python/python-keystoneclient/ChangeLog
+++ b/dev-python/python-keystoneclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-keystoneclient
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/ChangeLog,v 1.25 2014/01/06 10:44:44 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/ChangeLog,v 1.26 2014/02/17 17:44:54 prometheanfire Exp $
+
+*python-keystoneclient-0.6.0 (17 Feb 2014)
+
+ 17 Feb 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +python-keystoneclient-0.6.0.ebuild:
+ fix for a dep of a cve
06 Jan 2014; Ian Delaney <idella4@gentoo.org>
python-keystoneclient-0.4.1.ebuild:
diff --git a/dev-python/python-keystoneclient/python-keystoneclient-0.6.0.ebuild b/dev-python/python-keystoneclient/python-keystoneclient-0.6.0.ebuild
new file mode 100644
index 000000000000..05182aecd92c
--- /dev/null
+++ b/dev-python/python-keystoneclient/python-keystoneclient-0.6.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-0.6.0.ebuild,v 1.1 2014/02/17 17:44:54 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Keystone API"
+HOMEPAGE="https://github.com/openstack/python-keystoneclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.8[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/keyring-1.6.1[${PYTHON_USEDEP}]
+ <dev-python/keyring-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/webob-1.3[${PYTHON_USEDEP}]
+ ) "
+
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.8[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.6[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/sphinx_mapping.patch
+)
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # https://bugs.launchpad.net/python-keystoneclient/+bug/1243528
+ testr init
+ testr run || die "testsuite failed under python2.7"
+ flake8 ${PN/python-/}/tests || die "run over tests folder by flake8 drew error"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ use examples && local EXAMPLES=( examples/.)
+ distutils-r1_python_install_all
+}