summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-08-11 02:19:22 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-08-11 02:19:22 +0000
commitd8891f121cccad62a3843588bd085bdd136fa127 (patch)
tree2d90ec9da17c1ef082ee7dad747776c64da46e44 /dev-python
parentupdating swiftclient to 1.5.0 (diff)
downloadgentoo-2-d8891f121cccad62a3843588bd085bdd136fa127.tar.gz
gentoo-2-d8891f121cccad62a3843588bd085bdd136fa127.tar.bz2
gentoo-2-d8891f121cccad62a3843588bd085bdd136fa127.zip
just an update for cinderclient
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-cinderclient/ChangeLog8
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-1.0.5.ebuild (renamed from dev-python/python-cinderclient/python-cinderclient-1.0.2.ebuild)15
2 files changed, 18 insertions, 5 deletions
diff --git a/dev-python/python-cinderclient/ChangeLog b/dev-python/python-cinderclient/ChangeLog
index a620f3b447e0..31a64969f723 100644
--- a/dev-python/python-cinderclient/ChangeLog
+++ b/dev-python/python-cinderclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-cinderclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/ChangeLog,v 1.4 2013/05/16 01:21:30 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/ChangeLog,v 1.5 2013/08/11 02:19:22 prometheanfire Exp $
+
+*python-cinderclient-1.0.5 (11 Aug 2013)
+
+ 11 Aug 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +python-cinderclient-1.0.5.ebuild, -python-cinderclient-1.0.2.ebuild:
+ just an update for cinderclient
*python-cinderclient-1.0.4 (16 May 2013)
diff --git a/dev-python/python-cinderclient/python-cinderclient-1.0.2.ebuild b/dev-python/python-cinderclient/python-cinderclient-1.0.5.ebuild
index 124cbbbd1952..2d87b705496a 100644
--- a/dev-python/python-cinderclient/python-cinderclient-1.0.2.ebuild
+++ b/dev-python/python-cinderclient/python-cinderclient-1.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/python-cinderclient-1.0.2.ebuild,v 1.3 2013/03/19 22:39:59 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/python-cinderclient-1.0.5.ebuild,v 1.1 2013/08/11 02:19:22 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -15,6 +15,8 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+#restricting tests til upstream can decide on a testing infra, I'm tired of adding packages that stop getting used...
+RESTRICT="test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/fixtures[${PYTHON_USEDEP}]
@@ -27,9 +29,14 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
>=dev-python/testtools-0.9.22 )"
RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
- <=dev-python/prettytable-0.7
- <=dev-python/requests-1.0
- dev-python/simplejson[${PYTHON_USEDEP}]"
+ >=dev-python/pbr-0.5[${PYTHON_USEDEP}]
+ <dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ <dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.0.9[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
python_test() {
sh run_tests.sh -N -p -c