summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-04-18 13:19:07 +0000
committerAli Polatel <hawking@gentoo.org>2008-04-18 13:19:07 +0000
commitdb60c38f87a75eb1b078fd570126a3e639f12758 (patch)
tree426610e1ca5cf3c82cc10d1b8e4f6096755d0d9e /dev-python
parentFix compile problems with gcc-4.3 (see bug #218176). (diff)
downloadgentoo-2-db60c38f87a75eb1b078fd570126a3e639f12758.tar.gz
gentoo-2-db60c38f87a75eb1b078fd570126a3e639f12758.tar.bz2
gentoo-2-db60c38f87a75eb1b078fd570126a3e639f12758.zip
Version bump. Dropped old.
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pastescript/ChangeLog10
-rw-r--r--dev-python/pastescript/pastescript-1.6.2.ebuild (renamed from dev-python/pastescript/pastescript-1.1.ebuild)13
2 files changed, 18 insertions, 5 deletions
diff --git a/dev-python/pastescript/ChangeLog b/dev-python/pastescript/ChangeLog
index 70dfaa3a6144..bee7d0fe8435 100644
--- a/dev-python/pastescript/ChangeLog
+++ b/dev-python/pastescript/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pastescript
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/ChangeLog,v 1.3 2007/07/04 20:55:13 lucass Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/ChangeLog,v 1.4 2008/04/18 13:19:07 hawking Exp $
+
+*pastescript-1.6.2 (18 Apr 2008)
+
+ 18 Apr 2008; Ali Polatel <hawking@gentoo.org> -pastescript-1.1.ebuild,
+ +pastescript-1.6.2.ebuild:
+ Version bump. Dropped old.
04 Jul 2007; Lukasz Strzygowski <lucass@gentoo.org>
pastescript-1.1.ebuild:
diff --git a/dev-python/pastescript/pastescript-1.1.ebuild b/dev-python/pastescript/pastescript-1.6.2.ebuild
index 91dd8b3ea09c..7db893752228 100644
--- a/dev-python/pastescript/pastescript-1.1.ebuild
+++ b/dev-python/pastescript/pastescript-1.6.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/pastescript-1.1.ebuild,v 1.3 2007/07/04 20:55:13 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/pastescript-1.6.2.ebuild,v 1.1 2008/04/18 13:19:07 hawking Exp $
NEED_PYTHON=2.4
@@ -46,5 +46,12 @@ src_install() {
}
src_test() {
- PYTHONPATH=build/lib "${python}" setup.py nosetests || die "tests failed"
+ # Tests can't import paste from site-packages
+ # so we copy them over.
+ # The files that will be installed are already copied to build/lib
+ # so this shouldn't generate any collisions.
+ distutils_python_version
+ cp -pPR /usr/$(get_libdir)/python${PYVER}/site-packages/paste/* paste/
+
+ PYTHONPATH=. "${python}" setup.py nosetests || die "tests failed"
}