summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-01-17 22:42:33 +0000
committerPatrick McLean <chutzpah@gentoo.org>2013-01-17 22:42:33 +0000
commitdb6939ff33efdd808bbb4e12c176e01dfe8c3471 (patch)
treeb5205835955d94d90f89cac3dd240c1a2daaff3e /dev-python
parentfix build with ffmpeg-1, part of bug #443428 (diff)
downloadgentoo-2-db6939ff33efdd808bbb4e12c176e01dfe8c3471.tar.gz
gentoo-2-db6939ff33efdd808bbb4e12c176e01dfe8c3471.tar.bz2
gentoo-2-db6939ff33efdd808bbb4e12c176e01dfe8c3471.zip
Re-add python-3.3 support with a REQUIRED_USE to block doc from being enabled with python-3.3
(Portage version: 2.1.11.42/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/beautifulsoup/ChangeLog7
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.1.3-r1.ebuild8
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-python/beautifulsoup/ChangeLog b/dev-python/beautifulsoup/ChangeLog
index a58325fd48a6..9b08367ed0eb 100644
--- a/dev-python/beautifulsoup/ChangeLog
+++ b/dev-python/beautifulsoup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/beautifulsoup
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.81 2013/01/17 07:33:56 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.82 2013/01/17 22:42:33 chutzpah Exp $
+
+ 17 Jan 2013; Patrick McLean <chutzpah@gentoo.org>
+ beautifulsoup-4.1.3-r1.ebuild:
+ Re-add python-3.3 support with a REQUIRED_USE to block doc from being enabled
+ with python-3.3
*beautifulsoup-4.1.3-r1 (17 Jan 2013)
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.1.3-r1.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.1.3-r1.ebuild
index e80f4844961f..3e24dd962ca6 100644
--- a/dev-python/beautifulsoup/beautifulsoup-4.1.3-r1.ebuild
+++ b/dev-python/beautifulsoup/beautifulsoup-4.1.3-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-4.1.3-r1.ebuild,v 1.1 2013/01/17 07:33:56 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-4.1.3-r1.ebuild,v 1.2 2013/01/17 22:42:33 chutzpah Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} )
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
inherit distutils-r1
@@ -21,12 +21,14 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
IUSE="doc test"
DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}] )"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
+REQUIRED_USE="doc? ( !python_targets_python3_3 )"
+
python_compile_all() {
if use doc; then
emake -C doc html