summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-09 11:12:23 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-09 11:12:23 +0000
commite056c94320f7d3773577375f44b627f792b293be (patch)
treeff6574f28638b7868e2718920541b5e986ff0004 /dev-python
parentMigrate to twisted-r1. (diff)
downloadgentoo-2-e056c94320f7d3773577375f44b627f792b293be.tar.gz
gentoo-2-e056c94320f7d3773577375f44b627f792b293be.tar.bz2
gentoo-2-e056c94320f7d3773577375f44b627f792b293be.zip
Migrate to twisted-r1.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted-conch/ChangeLog7
-rw-r--r--dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/twisted-conch/ChangeLog b/dev-python/twisted-conch/ChangeLog
index 208b7192132b..34e3a040d8fd 100644
--- a/dev-python/twisted-conch/ChangeLog
+++ b/dev-python/twisted-conch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-conch
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/ChangeLog,v 1.86 2013/08/03 09:45:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/ChangeLog,v 1.87 2013/08/09 11:12:23 mgorny Exp $
+
+*twisted-conch-13.0.0-r1 (09 Aug 2013)
+
+ 09 Aug 2013; Michał Górny <mgorny@gentoo.org> +twisted-conch-13.0.0-r1.ebuild:
+ Migrate to twisted-r1.
03 Aug 2013; Michał Górny <mgorny@gentoo.org> twisted-conch-10.2.0.ebuild,
twisted-conch-11.0.0.ebuild, twisted-conch-11.1.0.ebuild,
diff --git a/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild b/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild
new file mode 100644
index 000000000000..3f27863a98ab
--- /dev/null
+++ b/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild,v 1.1 2013/08/09 11:12:23 mgorny Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit twisted-r1
+
+DESCRIPTION="Twisted SSHv2 implementation"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ =dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed -e "s/test_checkKeyAsRoot/_&/" -i twisted/conch/test/test_checkers.py
+ sed -e "s/test_getPrivateKeysAsRoot/_&/" -i twisted/conch/test/test_openssh_compat.py
+ fi
+}