summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-12 11:01:10 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-12 11:01:10 +0000
commitefd74c3fd9b421b16b3be2dcd8a96207a65fe262 (patch)
tree93e243552a9f7fa4dec34e4fd657d9860bfaaf00 /dev-python
parentInstall Twisted egg-info (bug #299736). Respect TWISTED_DISABLE_WRITING_OF_PL... (diff)
downloadgentoo-2-efd74c3fd9b421b16b3be2dcd8a96207a65fe262.tar.gz
gentoo-2-efd74c3fd9b421b16b3be2dcd8a96207a65fe262.tar.bz2
gentoo-2-efd74c3fd9b421b16b3be2dcd8a96207a65fe262.zip
Fix tests (bug #297470).
(Portage version: 15196-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nevow/ChangeLog8
-rw-r--r--dev-python/nevow/nevow-0.10.0.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/nevow/ChangeLog b/dev-python/nevow/ChangeLog
index bc08741eab81..8796bb718786 100644
--- a/dev-python/nevow/ChangeLog
+++ b/dev-python/nevow/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/nevow
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/ChangeLog,v 1.36 2009/11/30 03:10:32 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/ChangeLog,v 1.37 2010/01/12 11:01:10 arfrever Exp $
+
+ 12 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ nevow-0.10.0.ebuild:
+ Fix tests (bug #297470).
*nevow-0.10.0 (30 Nov 2009)
diff --git a/dev-python/nevow/nevow-0.10.0.ebuild b/dev-python/nevow/nevow-0.10.0.ebuild
index fb431eeb96fd..c92abd6285a1 100644
--- a/dev-python/nevow/nevow-0.10.0.ebuild
+++ b/dev-python/nevow/nevow-0.10.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/nevow-0.10.0.ebuild,v 1.1 2009/11/30 03:10:32 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/nevow-0.10.0.ebuild,v 1.2 2010/01/12 11:01:10 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -32,7 +32,7 @@ PYTHON_MODNAME="formless nevow"
src_test() {
testing() {
PYTHONPATH="build-${PYTHON_ABI}/lib" trial formless || die "formless trial failed with Python ${PYTHON_ABI}"
- PYTHONPATH="build-${PYTHON_ABI}/lib" trial nevow || die "nevow trial failed with Python ${PYTHON_ABI}"
+ PYTHONPATH="build-${PYTHON_ABI}/lib" TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE="1" trial nevow || die "nevow trial failed with Python ${PYTHON_ABI}"
}
python_execute_function testing
}
@@ -50,7 +50,7 @@ src_install() {
update_nevow_plugin_cache() {
einfo "Updating nevow plugin cache..."
- "$(PYTHON)" -c 'from twisted.plugin import IPlugin, getPlugIns;from nevow import plugins; list(getPlugIns(IPlugin, plugins))'
+ "$(PYTHON)" -c 'from twisted.plugin import IPlugin, getPlugins;from nevow import plugins; list(getPlugins(IPlugin, plugins))'
}
pkg_postrm() {