summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-03-05 08:12:42 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-03-05 08:12:42 +0000
commitf7a2941e9f3b5bf0716ddfc81ae6055b4be6bb75 (patch)
treee7b9e84d943de341540e7843c6d9902a9e9ee6be /dev-python
parentRe-enabling the perl,python,ruby bindings, thanks to a patch written by dleve... (diff)
downloadgentoo-2-f7a2941e9f3b5bf0716ddfc81ae6055b4be6bb75.tar.gz
gentoo-2-f7a2941e9f3b5bf0716ddfc81ae6055b4be6bb75.tar.bz2
gentoo-2-f7a2941e9f3b5bf0716ddfc81ae6055b4be6bb75.zip
Version bump, thanks to Brad Walker, keep the old version for stabilization
(Portage version: 2.1.2-r10)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/simplejson/ChangeLog7
-rw-r--r--dev-python/simplejson/files/digest-simplejson-1.63
-rw-r--r--dev-python/simplejson/simplejson-1.6.ebuild37
3 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index 31e1f002ca72..1f925fd60114 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.1 2007/02/27 23:59:45 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.2 2007/03/05 08:12:42 dev-zero Exp $
+
+*simplejson-1.6 (05 Mar 2007)
+
+ 05 Mar 2007; Tiziano Müller <dev-zero@gentoo.org> +simplejson-1.6.ebuild:
+ Version bump, thanks to Brad Walker, keep the old version for stabilization
05 Feb 2007; Tiziano Müller <dev-zero@gentoo.org> simplejson-1.5.ebuild:
Fixed ez_setup sed.
diff --git a/dev-python/simplejson/files/digest-simplejson-1.6 b/dev-python/simplejson/files/digest-simplejson-1.6
new file mode 100644
index 000000000000..014fbc6c3319
--- /dev/null
+++ b/dev-python/simplejson/files/digest-simplejson-1.6
@@ -0,0 +1,3 @@
+MD5 be3e13943a9627a3cfc012e31db0550b simplejson-1.6.tar.gz 56204
+RMD160 f956e274e9d53d0ab28072f437c0b8eab8f08bc0 simplejson-1.6.tar.gz 56204
+SHA256 e901c0e78ceba9b3679ddccad5dd48e6dd84f087dc288a2e24e5c6d875a4f735 simplejson-1.6.tar.gz 56204
diff --git a/dev-python/simplejson/simplejson-1.6.ebuild b/dev-python/simplejson/simplejson-1.6.ebuild
new file mode 100644
index 000000000000..3a2cd4ed1805
--- /dev/null
+++ b/dev-python/simplejson/simplejson-1.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-1.6.ebuild,v 1.1 2007/03/05 08:12:42 dev-zero Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A simple, fast, complete, correct and extensible JSON encoder and decoder."
+HOMEPAGE="http://undefined.org/python/#simplejson"
+SRC_URI="http://cheeseshop.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( dev-python/nose )
+ dev-python/setuptools"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^ez_setup/d' -e '/^import ez_setup/d' \
+ setup.py || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+ dohtml -r docs/*
+}
+
+src_test() {
+ PYTHONPATH=. "${python}" setup.py test || die "test failed"
+}