summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-01-15 00:32:54 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-01-15 00:32:54 +0000
commitff493fb078443b877786a2c8fbe366117709a4db (patch)
treeff82b42c4e2ca1b29a9a51851716d19db60dab85 /dev-python
parentwas missing (diff)
downloadgentoo-2-ff493fb078443b877786a2c8fbe366117709a4db.tar.gz
gentoo-2-ff493fb078443b877786a2c8fbe366117709a4db.tar.bz2
gentoo-2-ff493fb078443b877786a2c8fbe366117709a4db.zip
Integrated the new tcl-tk scheme. This hasn't been tested much, so people
using these applications, please try it out. I've done this to advance the new scheme and start the testing of it. It's a good thing that tcl and tk are seperated, and the earlier the better.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Imaging/Imaging-1.1.2-r1.ebuild5
-rw-r--r--dev-python/Imaging/Imaging-1.1.2.ebuild102
-rw-r--r--dev-python/anygui/anygui-0.1_beta1.ebuild3
3 files changed, 2 insertions, 108 deletions
diff --git a/dev-python/Imaging/Imaging-1.1.2-r1.ebuild b/dev-python/Imaging/Imaging-1.1.2-r1.ebuild
index 77edb81d5c30..880f44c42436 100644
--- a/dev-python/Imaging/Imaging-1.1.2-r1.ebuild
+++ b/dev-python/Imaging/Imaging-1.1.2-r1.ebuild
@@ -14,11 +14,8 @@ HOMEPAGE="http://www.pythonware.com/downloads/#pil"
DEPEND=">=dev-lang/python-2.0
>=media-libs/jpeg-6a
>=sys-libs/zlib-0.95
- tcltk? ( dev-lang/tcl-tk )"
+ tcltk? ( dev-lang/tk )"
-#Change tcltk dependency to: tcltk? ( dev-tcltk/tk ),
-#if my separated tcl and tk ebuilds ever make it in portage tree.
-
RDEPEND="${DEPEND}"
src_compile() {
diff --git a/dev-python/Imaging/Imaging-1.1.2.ebuild b/dev-python/Imaging/Imaging-1.1.2.ebuild
deleted file mode 100644
index 5c95572672a2..000000000000
--- a/dev-python/Imaging/Imaging-1.1.2.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Tod Neidt <tneidt@fidnet.com>
-# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="Python Imaging Library (PIL)."
-
-SRC_URI="http://www.pythonware.com/downloads/${P}.tar.gz"
-
-HOMEPAGE="http://www.pythonware.com/downloads/#pil"
-
-DEPEND=">=dev-lang/python-2.0
- >=media-libs/jpeg-6a
- >=sys-libs/zlib-0.95
- tcltk? ( dev-lang/tcl-tk )"
-
-#Change tcltk dependency to: tcltk? ( dev-tcltk/tk ),
-#if my separated tcl and tk ebuilds ever make it in portage tree.
-
-RDEPEND="${DEPEND}"
-
-src_compile() {
-
- #This is a goofy build.
-
- #Build the core imaging library (libImaging.a)
- cd ${S}/libImaging
-
- ./configure --prefix=/usr \
- --host=${CHOST} || die
- cp Makefile Makefile.orig
-
- #Not configured by configure
- sed \
- -e "s:\(JPEGINCLUDE=[[:blank:]]*/usr/\)local/\(include\).*:\1\2:" \
- -e "s:\(OPT=[[:blank:]]*\).*:\1${CFLAGS}:" \
- Makefile.orig > Makefile
-
- emake || die
-
- #Build loadable python modules
- cd ${S}
-
- local scmd=""
-
- #First change all the "/usr/local" to "/usr"
- scmd="$scmd s:/usr/local:/usr:g;"
-
- # adjust for USE tcltk
- if use tcltk; then
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
- # adjust Setup to match
- scmd="$scmd s/-ltcl[0-9.]* -ltk[0-9.]*/-ltcl$tclv -ltk$tkv/;"
- else
- scmd="$scmd s:\(^_imagingtk\):#\1:;"
- fi
-
- sed "$scmd" Setup.in > Setup
-
- #No configure (#$%@!%%)
- scmd=""
- cp Makefile.pre.in Makefile.pre.in.orig
- #change all the "/usr/local" to "/usr" (haven't we been here before)
- scmd="$scmd s:/usr/local:/usr:g;"
- #fix man paths
- scmd="$scmd "'s:^\(MANDIR=.*/\)\(man\):\1share/\2:;'
- #Insert make.conf CFLAGS settings
- scmd="$scmd "'s:$(OPT)'":${CFLAGS}:;"
-
- sed "$scmd" Makefile.pre.in.orig > Makefile.pre.in
-
- #Now generate a top level Makefile
- make -f Makefile.pre.in boot || die
-
- emake || die
-
-}
-
-src_install () {
-
- #grab python verision so ebuild doesn't depend on it
- local pv
- pv=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
-
-
- insinto /usr/lib/python$pv/site-packages
- doins PIL.pth
-
- insinto /usr/lib/python$pv/site-packages/PIL
- doins _imaging.so PIL/*
- use tcltk && doins _imagingtk.so
-
- dodoc CHANGES CONTENTS FORMATS README
-
-}
-
diff --git a/dev-python/anygui/anygui-0.1_beta1.ebuild b/dev-python/anygui/anygui-0.1_beta1.ebuild
index 694266196b08..7cbd0856acf7 100644
--- a/dev-python/anygui/anygui-0.1_beta1.ebuild
+++ b/dev-python/anygui/anygui-0.1_beta1.ebuild
@@ -13,8 +13,7 @@ DEPEND=">=dev-lang/python-2.0
sys-libs/ncurses
qt? ( dev-python/PyQt )
gtk? ( dev-python/pygtk )
- tcltk? ( dev-lang/tcl-tk-8.3.3 )"
- #tcltk? ( dev-tcltk/tk-8.3.3 ) if my tcl and tk ebuilds are commited
+ tcltk? ( dev-lang/tk-8.3.3 )"
#future:
# might need a wxw use variable for wxGTK for wxw? ( dev-python/wxPython )
# also use variable fltk for fltk? ( dev-python/PyFLTK ) no ebuild for PyFLTK yet