summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 03:49:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 03:49:38 +0000
commitfc35a1ea1c3cc5a3b58c0c4a2da08d024d0f22ab (patch)
tree000f05074b21e1075e1c75b7846fab32b646f22b /dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild
parentPort to rspec helper for testing. Drop bundler dependency. (diff)
downloadgentoo-2-fc35a1ea1c3cc5a3b58c0c4a2da08d024d0f22ab.tar.gz
gentoo-2-fc35a1ea1c3cc5a3b58c0c4a2da08d024d0f22ab.tar.bz2
gentoo-2-fc35a1ea1c3cc5a3b58c0c4a2da08d024d0f22ab.zip
Port to rspec helper for testing. Bump to EAPI 4.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild')
-rw-r--r--dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild b/dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild
index 562dc7ff0a48..b0f98d72a6e9 100644
--- a/dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild
+++ b/dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild,v 1.2 2012/03/08 15:25:33 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IO-Reactor/IO-Reactor-1.0.4.ebuild,v 1.3 2012/08/14 03:49:38 flameeyes Exp $
-EAPI="2"
+EAPI=4
USE_RUBY="ruby18"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
RUBY_FAKEGEM_DOCDIR="docs/html"
RUBY_FAKEGEM_EXTRADOC="ChangeLog README"
@@ -21,7 +23,9 @@ SLOT="0"
KEYWORDS="~amd64 ppc64 ~x86 ~x86-fbsd"
IUSE="examples"
-ruby_add_bdepend test dev-ruby/rspec
+all_ruby_prepare() {
+ sed -i -e '/require.*spec/d' spec/io/reactor_spec.rb || die
+}
all_ruby_install() {
all_fakegem_install