summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-07 12:35:20 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-07 12:35:20 +0000
commit02c11b3e70bdef660a4acc76b385abfda9307f35 (patch)
treef7bd90eab95a211297b97fa120c0009a9ff28807 /dev-ruby/actionmailer
parentVersion bump for Rails 4. Dropped keywords in bug 487206. (diff)
downloadgentoo-2-02c11b3e70bdef660a4acc76b385abfda9307f35.tar.gz
gentoo-2-02c11b3e70bdef660a4acc76b385abfda9307f35.tar.bz2
gentoo-2-02c11b3e70bdef660a4acc76b385abfda9307f35.zip
Version bump for Rails 4. Dropped keywords in bug 487206.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.0.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 6aa766d25e08..79a57978d134 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.240 2013/08/17 10:32:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.241 2013/10/07 12:35:20 graaff Exp $
+
+*actionmailer-4.0.0 (07 Oct 2013)
+
+ 07 Oct 2013; Hans de Graaff <graaff@gentoo.org> +actionmailer-4.0.0.ebuild:
+ Version bump for Rails 4. Dropped keywords in bug 487206.
*actionmailer-3.2.14 (17 Aug 2013)
diff --git a/dev-ruby/actionmailer/actionmailer-4.0.0.ebuild b/dev-ruby/actionmailer/actionmailer-4.0.0.ebuild
new file mode 100644
index 000000000000..86c1c6b6f997
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-4.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.0.0.ebuild,v 1.1 2013/10/07 12:35:20 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.5.3:2.5"
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:0.13
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+}