summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-04 09:34:48 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-04 09:34:48 +0000
commite1d4a485f7b7f0c1a77fd9c46ea9142f7356c21f (patch)
tree2d44d99c341273e0f1a00483648d6bce602dace9 /dev-ruby/actionmailer
parentVersion bump for Rails 3.0.9. (diff)
downloadgentoo-2-e1d4a485f7b7f0c1a77fd9c46ea9142f7356c21f.tar.gz
gentoo-2-e1d4a485f7b7f0c1a77fd9c46ea9142f7356c21f.tar.bz2
gentoo-2-e1d4a485f7b7f0c1a77fd9c46ea9142f7356c21f.zip
Version bump for Rails 3.0.9.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.0.9.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index a361c43af931..a111bc2eb0bb 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.158 2011/06/09 17:08:48 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.159 2011/07/04 09:34:48 graaff Exp $
+
+*actionmailer-3.0.9 (04 Jul 2011)
+
+ 04 Jul 2011; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.0.9.ebuild:
+ Version bump for Rails 3.0.9.
*actionmailer-2.3.12 (09 Jun 2011)
diff --git a/dev-ruby/actionmailer/actionmailer-3.0.9.ebuild b/dev-ruby/actionmailer/actionmailer-3.0.9.ebuild
new file mode 100644
index 000000000000..102f651eb87f
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.0.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.0.9.ebuild,v 1.1 2011/07/04 09:34:48 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.2.19"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}