summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-26 18:04:55 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-26 18:04:55 +0000
commitee86b64954ab939d0152a444260abca1da0b2d22 (patch)
tree831a24a1a3521736b246c11b8bdfefa0bc0fb320 /dev-ruby/actionmailer
parentDelete older ebuilds. (diff)
downloadgentoo-2-ee86b64954ab939d0152a444260abca1da0b2d22.tar.gz
gentoo-2-ee86b64954ab939d0152a444260abca1da0b2d22.tar.bz2
gentoo-2-ee86b64954ab939d0152a444260abca1da0b2d22.zip
Version bump for Rails 3.0.7.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog8
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.0.7.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 2341e5874246..c3fa5f1c007f 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.154 2011/02/21 20:10:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.155 2011/04/26 18:04:55 graaff Exp $
+
+*actionmailer-3.0.7 (26 Apr 2011)
+
+ 26 Apr 2011; Hans de Graaff <graaff@gentoo.org>
+ +actionmailer-3.0.7.ebuild:
+ Version bump for Rails 3.0.7.
*actionmailer-2.3.11 (21 Feb 2011)
diff --git a/dev-ruby/actionmailer/actionmailer-3.0.7.ebuild b/dev-ruby/actionmailer/actionmailer-3.0.7.ebuild
new file mode 100644
index 000000000000..3705644617c8
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.0.7.ebuild,v 1.1 2011/04/26 18:04:55 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.2.15"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}