summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-04 09:25:27 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-04 09:25:27 +0000
commite749bf6331e3b1cc86aae0c9d9f8b40d701a8e1a (patch)
treed632099a217154606c6159d5235bdf8b5d656d43 /dev-ruby/activemodel/activemodel-3.0.12.ebuild
parentVersion bump for security bug 406547. (diff)
downloadgentoo-2-e749bf6331e3b1cc86aae0c9d9f8b40d701a8e1a.tar.gz
gentoo-2-e749bf6331e3b1cc86aae0c9d9f8b40d701a8e1a.tar.bz2
gentoo-2-e749bf6331e3b1cc86aae0c9d9f8b40d701a8e1a.zip
Version bump for security bug 406547.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activemodel/activemodel-3.0.12.ebuild')
-rw-r--r--dev-ruby/activemodel/activemodel-3.0.12.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/activemodel/activemodel-3.0.12.ebuild b/dev-ruby/activemodel/activemodel-3.0.12.ebuild
new file mode 100644
index 000000000000..e6154f2c85e8
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.0.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.0.12.ebuild,v 1.1 2012/04/04 09:25:27 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2
+ >=dev-ruby/i18n-0.5.0:0.5"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/ruby-debug
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}