summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-07 12:34:44 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-07 12:34:44 +0000
commit6dc310d5501912df101fc2cef3e9192233ca5c76 (patch)
treebfa3c63f7474c49fa115e33ee5869c69734ab25a /dev-ruby/activemodel
parentVersion bump for Rails 4. Dropped keywords in bug 487206. (diff)
downloadgentoo-2-6dc310d5501912df101fc2cef3e9192233ca5c76.tar.gz
gentoo-2-6dc310d5501912df101fc2cef3e9192233ca5c76.tar.bz2
gentoo-2-6dc310d5501912df101fc2cef3e9192233ca5c76.zip
Version bump for Rails 4. Dropped keywords in bug 487206.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-4.0.0.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index b57b72344d44..b3efb3d4963c 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.59 2013/08/17 10:31:06 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.60 2013/10/07 12:34:44 graaff Exp $
+
+*activemodel-4.0.0 (07 Oct 2013)
+
+ 07 Oct 2013; Hans de Graaff <graaff@gentoo.org> +activemodel-4.0.0.ebuild:
+ Version bump for Rails 4. Dropped keywords in bug 487206.
*activemodel-3.2.14 (17 Aug 2013)
diff --git a/dev-ruby/activemodel/activemodel-4.0.0.ebuild b/dev-ruby/activemodel/activemodel-4.0.0.ebuild
new file mode 100644
index 000000000000..98b48c34bfd0
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-4.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-4.0.0.ebuild,v 1.1 2013/10/07 12:34:44 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1.0:3.1
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/railties-4.0.0
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.13.0:0.13
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+
+ # Fix bcrypt dependency since bcrypt uses semantic versioning.
+ sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' lib/active_model/secure_password.rb || die
+}