summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-09-12 06:27:09 +0000
committerHans de Graaff <graaff@gentoo.org>2014-09-12 06:27:09 +0000
commite044b95a6da803c8917b2bca03027cf7a7c63537 (patch)
treec48a0d9d9ddae568bf49152124cf0377c222c48c /dev-ruby/activemodel
parentVersion bump. (diff)
downloadgentoo-2-e044b95a6da803c8917b2bca03027cf7a7c63537.tar.gz
gentoo-2-e044b95a6da803c8917b2bca03027cf7a7c63537.tar.bz2
gentoo-2-e044b95a6da803c8917b2bca03027cf7a7c63537.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-4.1.6.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index f4a5eb98b977..1e85ead69547 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.91 2014/09/12 05:55:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.92 2014/09/12 06:27:09 graaff Exp $
+
+*activemodel-4.1.6 (12 Sep 2014)
+
+ 12 Sep 2014; Hans de Graaff <graaff@gentoo.org> +activemodel-4.1.6.ebuild:
+ Version bump.
*activemodel-4.0.10 (12 Sep 2014)
diff --git a/dev-ruby/activemodel/activemodel-4.1.6.ebuild b/dev-ruby/activemodel/activemodel-4.1.6.ebuild
new file mode 100644
index 000000000000..5a9cb3beceb7
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-4.1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-4.1.6.ebuild,v 1.1 2014/09/12 06:27:09 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource"
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1.0:3.1
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/railties-4.0.0
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.14.0:0.14
+ >=dev-ruby/bcrypt-ruby-3.1.7
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}