summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-09-13 09:06:38 +0000
committerHans de Graaff <graaff@gentoo.org>2008-09-13 09:06:38 +0000
commit1c98c68e1228738313fa5a5268d191366b34456f (patch)
tree4e5217cc56cd6facb1e829e14af569ed444f244f /dev-ruby/activerecord
parentVersion bump for Rails 2.1.1, bug #237392 (diff)
downloadgentoo-2-1c98c68e1228738313fa5a5268d191366b34456f.tar.gz
gentoo-2-1c98c68e1228738313fa5a5268d191366b34456f.tar.bz2
gentoo-2-1c98c68e1228738313fa5a5268d191366b34456f.zip
Version bump for Rails 2.1.1, bug #237392
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-2.1.1.ebuild21
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index bd171dd776f6..25c41e49443d 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.80 2008/09/12 05:56:06 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.81 2008/09/13 09:06:38 graaff Exp $
+
+*activerecord-2.1.1 (13 Sep 2008)
+
+ 13 Sep 2008; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-2.1.1.ebuild:
+ Version bump for Rails 2.1.1, bug #237392
*activerecord-2.0.4 (12 Sep 2008)
diff --git a/dev-ruby/activerecord/activerecord-2.1.1.ebuild b/dev-ruby/activerecord/activerecord-2.1.1.ebuild
new file mode 100644
index 000000000000..8ae2de0cdbe5
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.1.1.ebuild,v 1.1 2008/09/13 09:06:38 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ ~dev-ruby/activesupport-2.1.1
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"