summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-11-28 09:29:55 +0000
committerAlex Legler <a3li@gentoo.org>2009-11-28 09:29:55 +0000
commit1f1ff3b5d3e8d92ea50acfc9aa22c03091c70de5 (patch)
tree3a80114042f49de2441b35dc035741c88a858bbe /dev-ruby/activerecord
parentVersion bump, security bug 294797 (diff)
downloadgentoo-2-1f1ff3b5d3e8d92ea50acfc9aa22c03091c70de5.tar.gz
gentoo-2-1f1ff3b5d3e8d92ea50acfc9aa22c03091c70de5.tar.bz2
gentoo-2-1f1ff3b5d3e8d92ea50acfc9aa22c03091c70de5.zip
Version bump, security bug 294797
(Portage version: 2.2_rc52/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.5.ebuild22
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 28a6566b4906..91ff9655376b 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.119 2009/10/22 08:08:07 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.120 2009/11/28 09:29:54 a3li Exp $
+
+*activerecord-2.3.5 (28 Nov 2009)
+
+ 28 Nov 2009; Alex Legler <a3li@gentoo.org> +activerecord-2.3.5.ebuild:
+ Version bump, security bug 294797
22 Oct 2009; Alex Legler <a3li@gentoo.org> -activerecord-1.15.6.ebuild,
-activerecord-2.0.5.ebuild, -activerecord-2.1.2.ebuild:
diff --git a/dev-ruby/activerecord/activerecord-2.3.5.ebuild b/dev-ruby/activerecord/activerecord-2.3.5.ebuild
new file mode 100644
index 000000000000..1847ffc212d2
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.5.ebuild,v 1.1 2009/11/28 09:29:55 a3li Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+
+DEPEND=">=dev-lang/ruby-1.8.6
+ ~dev-ruby/activesupport-${PV}"
+RDEPEND="${DEPEND}
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"