summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-06-17 05:40:54 +0000
committerHans de Graaff <graaff@gentoo.org>2008-06-17 05:40:54 +0000
commitbc7e74c90fdbd52989239c34dc967228469902d8 (patch)
treeb5da6b80b7f7e1ee97dd45d287d78bf2295fb7ce /dev-ruby/activerecord
parentVersion bump for Rails 2.1.0 (diff)
downloadgentoo-2-bc7e74c90fdbd52989239c34dc967228469902d8.tar.gz
gentoo-2-bc7e74c90fdbd52989239c34dc967228469902d8.tar.bz2
gentoo-2-bc7e74c90fdbd52989239c34dc967228469902d8.zip
Version bump for Rails 2.1.0
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/activerecord-2.1.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/activerecord/activerecord-2.1.0.ebuild b/dev-ruby/activerecord/activerecord-2.1.0.ebuild
new file mode 100644
index 000000000000..e32bb08a0980
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.1.0.ebuild,v 1.1 2008/06/17 05:40:54 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ ~dev-ruby/activesupport-2.1.0
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"