summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-11-10 14:42:04 +0000
committerHans de Graaff <graaff@gentoo.org>2013-11-10 14:42:04 +0000
commitf0414bd1e0750f194c7f8960e4eb6e9bb48a5399 (patch)
tree227c971d6250cb8a0cb420d686a46da1ac4a2138 /dev-ruby/activerecord
parentCleanup. (diff)
downloadgentoo-2-f0414bd1e0750f194c7f8960e4eb6e9bb48a5399.tar.gz
gentoo-2-f0414bd1e0750f194c7f8960e4eb6e9bb48a5399.tar.bz2
gentoo-2-f0414bd1e0750f194c7f8960e4eb6e9bb48a5399.zip
Cleanup.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog6
-rw-r--r--dev-ruby/activerecord/activerecord-3.2.13.ebuild75
-rw-r--r--dev-ruby/activerecord/activerecord-3.2.14.ebuild76
3 files changed, 5 insertions, 152 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 8dbdab25db7b..bc3be0fb9977 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.246 2013/10/17 06:37:26 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.247 2013/11/10 14:42:04 graaff Exp $
+
+ 10 Nov 2013; Hans de Graaff <graaff@gentoo.org> -activerecord-3.2.13.ebuild,
+ -activerecord-3.2.14.ebuild:
+ Cleanup.
*activerecord-3.2.15 (17 Oct 2013)
diff --git a/dev-ruby/activerecord/activerecord-3.2.13.ebuild b/dev-ruby/activerecord/activerecord-3.2.13.ebuild
deleted file mode 100644
index 3072fc7e4f2b..000000000000
--- a/dev-ruby/activerecord/activerecord-3.2.13.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.2.13.ebuild,v 1.2 2013/10/13 16:04:35 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-3.0.2:3.0
- >=dev-ruby/tzinfo-0.3.29:0
- sqlite3? ( >=dev-ruby/sqlite3-1.3.5 )
- mysql? ( >=dev-ruby/mysql2-0.3.10:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.5
- >=dev-ruby/mocha-0.12.1
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\)/d" ../Gemfile || die
- sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
- sed -i -e 's/= 0.6.1/~> 0.6.1/' ../activesupport/activesupport.gemspec || die
-
- # Avoid tests depending on hash ordering
- sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
-
- # Avoid test depending on mysql adapter which we don't support for
- # this Rails version to simplify our dependencies.
- rm test/cases/connection_specification/resolver_test.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *rubyee18)
- # Turn on travis support to avoid tripping bugs in ree18.
- TRAVIS=true ${RUBY} -S rake test_sqlite3
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-3.2.14.ebuild b/dev-ruby/activerecord/activerecord-3.2.14.ebuild
deleted file mode 100644
index 223800a80805..000000000000
--- a/dev-ruby/activerecord/activerecord-3.2.14.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.2.14.ebuild,v 1.2 2013/10/13 16:04:35 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-3.0.2:3.0
- >=dev-ruby/tzinfo-0.3.29:0
- sqlite3? ( >=dev-ruby/sqlite3-1.3.5 )
- mysql? ( >=dev-ruby/mysql2-0.3.10:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.5
- dev-ruby/mocha:0.13
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\)/d" ../Gemfile || die
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-
- sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
-
- # Avoid tests depending on hash ordering
- sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
-
- # Avoid test depending on mysql adapter which we don't support for
- # this Rails version to simplify our dependencies.
- rm test/cases/connection_specification/resolver_test.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *rubyee18)
- # Turn on travis support to avoid tripping bugs in ree18.
- TRAVIS=true ${RUBY} -S rake test_sqlite3
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}