summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-10 06:43:21 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-10 06:43:21 +0000
commitba6a26913c8d7a251299998150bfac5ba8721000 (patch)
tree9567f49a40761eb612309650c92d307faae3a874 /dev-ruby/activeresource
parentVersion bump for security bug 430718. (diff)
downloadgentoo-2-ba6a26913c8d7a251299998150bfac5ba8721000.tar.gz
gentoo-2-ba6a26913c8d7a251299998150bfac5ba8721000.tar.bz2
gentoo-2-ba6a26913c8d7a251299998150bfac5ba8721000.zip
Version bump for security bug 430718.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activeresource')
-rw-r--r--dev-ruby/activeresource/ChangeLog7
-rw-r--r--dev-ruby/activeresource/activeresource-3.2.8.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index c283221b1222..1ba0052dee3a 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.118 2012/07/29 07:42:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.119 2012/08/10 06:43:21 graaff Exp $
+
+*activeresource-3.2.8 (10 Aug 2012)
+
+ 10 Aug 2012; Hans de Graaff <graaff@gentoo.org> +activeresource-3.2.8.ebuild:
+ Version bump for security bug 430718.
29 Jul 2012; Hans de Graaff <graaff@gentoo.org>
-activeresource-3.0.15.ebuild, -activeresource-3.1.6.ebuild,
diff --git a/dev-ruby/activeresource/activeresource-3.2.8.ebuild b/dev-ruby/activeresource/activeresource-3.2.8.ebuild
new file mode 100644
index 000000000000..6a836a86b13d
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.2.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.2.8.ebuild,v 1.1 2012/08/10 06:43:21 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}