summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-08-17 08:37:33 +0000
committerHans de Graaff <graaff@gentoo.org>2011-08-17 08:37:33 +0000
commit7d2ba21fe54557733458f76d73b8181d96e361b2 (patch)
tree6bf6be1df5a43fba438b377e62e962ae4fb56c56 /dev-ruby/activesupport/activesupport-2.3.14.ebuild
parentVersion Bump (diff)
downloadgentoo-2-7d2ba21fe54557733458f76d73b8181d96e361b2.tar.gz
gentoo-2-7d2ba21fe54557733458f76d73b8181d96e361b2.tar.bz2
gentoo-2-7d2ba21fe54557733458f76d73b8181d96e361b2.zip
Version bump.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activesupport/activesupport-2.3.14.ebuild')
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.14.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/activesupport-2.3.14.ebuild b/dev-ruby/activesupport/activesupport-2.3.14.ebuild
new file mode 100644
index 000000000000..da669987fe0f
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.14.ebuild,v 1.1 2011/08/17 08:37:33 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2:0 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.4.1:0.4"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
+ || die "failed to remove vendor packages"
+
+ # This patch removes the fallback to local vendorized gems, as
+ # well as fixing the dependencies for i18n to use the correct
+ # slot.
+ epatch "${FILESDIR}"/${PN}-2.3.9-unvendorize.patch
+
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
+}