summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-08 19:38:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-08 19:38:36 +0000
commit7c39ba08d7acb72aaafcc0e96992b7f5ba9e2a62 (patch)
treef1444b819be39811cb4a2271210a399f61579718 /dev-ruby/activesupport/activesupport-3.0.11.ebuild
parentAdd missing virtual/ruby-test-unit dependency to stay on the safe side; fix t... (diff)
downloadgentoo-2-7c39ba08d7acb72aaafcc0e96992b7f5ba9e2a62.tar.gz
gentoo-2-7c39ba08d7acb72aaafcc0e96992b7f5ba9e2a62.tar.bz2
gentoo-2-7c39ba08d7acb72aaafcc0e96992b7f5ba9e2a62.zip
Fix specifications so that they can be used with bundler (required for radiant-1). Also add mocha to the list of test dependencies for 3.0, found while installing the wrong slot.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activesupport/activesupport-3.0.11.ebuild')
-rw-r--r--dev-ruby/activesupport/activesupport-3.0.11.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/activesupport/activesupport-3.0.11.ebuild b/dev-ruby/activesupport/activesupport-3.0.11.ebuild
index 8ec9762babf4..7ff0cd4b3a6f 100644
--- a/dev-ruby/activesupport/activesupport-3.0.11.ebuild
+++ b/dev-ruby/activesupport/activesupport-3.0.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.11.ebuild,v 1.1 2011/11/19 10:53:57 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.11.ebuild,v 1.2 2011/12/08 19:38:36 flameeyes Exp $
EAPI=4
@@ -30,7 +30,7 @@ ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8"
# libxml-ruby and nokogiri are not strictly needed, but there are tests
# using this code.
-ruby_add_bdepend "test? ( virtual/ruby-test-unit >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri )"
+ruby_add_bdepend "test? ( virtual/ruby-test-unit >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri dev-ruby/mocha )"
all_ruby_prepare() {
# don't support older mocha versions as the optional codepath