summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-26 18:00:52 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-26 18:00:52 +0000
commitf76127537b9cadf26125e03f5e5a92f64e16ed7f (patch)
tree3f73060eacc2d289a420fcfff5ab750577c603a6 /dev-ruby/activesupport/activesupport-3.0.7.ebuild
parentold (diff)
downloadgentoo-2-f76127537b9cadf26125e03f5e5a92f64e16ed7f.tar.gz
gentoo-2-f76127537b9cadf26125e03f5e5a92f64e16ed7f.tar.bz2
gentoo-2-f76127537b9cadf26125e03f5e5a92f64e16ed7f.zip
Version bump for Rails 3.0.7.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activesupport/activesupport-3.0.7.ebuild')
-rw-r--r--dev-ruby/activesupport/activesupport-3.0.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/activesupport-3.0.7.ebuild b/dev-ruby/activesupport/activesupport-3.0.7.ebuild
new file mode 100644
index 000000000000..025cee154fa7
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.0.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.7.ebuild,v 1.1 2011/04/26 18:00:52 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8"
+
+# libxml-ruby and nokogiri are not strictly needed, but there are tests
+# using this code.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri )"
+
+all_ruby_prepare() {
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
+
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}