summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-10-31 08:55:50 +0000
committerHans de Graaff <graaff@gentoo.org>2014-10-31 08:55:50 +0000
commit00c1fbf10c0ae3440e134e4f80ff09bfaeaa31d3 (patch)
treeb1a82c107dff86ddea2ae71e0bb856c957b2aa0a /dev-ruby/activesupport
parentMove to ~ppc, bug #525258 (diff)
downloadgentoo-2-00c1fbf10c0ae3440e134e4f80ff09bfaeaa31d3.tar.gz
gentoo-2-00c1fbf10c0ae3440e134e4f80ff09bfaeaa31d3.tar.bz2
gentoo-2-00c1fbf10c0ae3440e134e4f80ff09bfaeaa31d3.zip
Version bump for security issue CVE-2014-7818.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog10
-rw-r--r--dev-ruby/activesupport/activesupport-3.2.20.ebuild71
-rw-r--r--dev-ruby/activesupport/activesupport-4.0.11.ebuild61
-rw-r--r--dev-ruby/activesupport/activesupport-4.1.7.ebuild61
4 files changed, 202 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index ba9444664128..e4b95861882c 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.270 2014/09/12 06:27:00 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.271 2014/10/31 08:55:50 graaff Exp $
+
+*activesupport-4.1.7 (31 Oct 2014)
+*activesupport-4.0.11 (31 Oct 2014)
+*activesupport-3.2.20 (31 Oct 2014)
+
+ 31 Oct 2014; Hans de Graaff <graaff@gentoo.org> +activesupport-3.2.20.ebuild,
+ +activesupport-4.0.11.ebuild, +activesupport-4.1.7.ebuild:
+ Version bump for security issue CVE-2014-7818.
*activesupport-4.1.6 (12 Sep 2014)
diff --git a/dev-ruby/activesupport/activesupport-3.2.20.ebuild b/dev-ruby/activesupport/activesupport-3.2.20.ebuild
new file mode 100644
index 000000000000..69fb12cc164b
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.2.20.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.2.20.ebuild,v 1.1 2014/10/31 08:55:50 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/multi_json-1.0
+ >=dev-ruby/i18n-0.6.4:0.6
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ >=dev-ruby/memcache-client-1.5.8
+ dev-ruby/nokogiri
+ >=dev-ruby/builder-3.0.3:3
+ >=dev-ruby/tzinfo-0.3.29
+ )"
+
+# libxml is not strictly needed, there are tests using this code. jruby
+# uses a different xml implementation.
+USE_RUBY=${USE_RUBY/jruby/} ruby_add_bdepend "test? ( >=dev-ruby/libxml-2.0.0 )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Ignore failing tests on jruby in the interest of a security update
+ sed -i -e '/test_not_allowed_to_expand_parameter_entities_to_files/,/^ end/ s:^:#:' \
+ -e '/test_exception_thrown_on_expansion_attack/,/^ end/ s:^:#:' \
+ test/xml_mini/jdom_engine_test.rb || die
+ sed -i \
+ -e '/test_exception_thrown_on_expansion_attack/,/^ end/ s:^:#:' \
+ test/xml_mini/nokogiri_engine_test.rb || die
+ ;;
+ esac
+}
diff --git a/dev-ruby/activesupport/activesupport-4.0.11.ebuild b/dev-ruby/activesupport/activesupport-4.0.11.ebuild
new file mode 100644
index 000000000000..a93849c4d2bd
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-4.0.11.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-4.0.11.ebuild,v 1.1 2014/10/31 08:55:50 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/multi_json-1.3:0
+ >=dev-ruby/i18n-0.6.9:0.6
+ >=dev-ruby/tzinfo-0.3.37:0
+ >=dev-ruby/minitest-4.2:0
+ >=dev-ruby/thread_safe-0.1:0
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/libxml-2.0.0
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure a compatible version of minitest is used everywhere.
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 4.2'/" lib/active_support/test_case.rb || die
+ sed -i -e "1igem 'minitest', '~> 4.2'" test/abstract_unit.rb || die
+
+ # Avoid test that seems to be broken by lack of DST.
+ sed -i -e '324 s:^:#:' test/core_ext/string_ext_test.rb || die
+}
diff --git a/dev-ruby/activesupport/activesupport-4.1.7.ebuild b/dev-ruby/activesupport/activesupport-4.1.7.ebuild
new file mode 100644
index 000000000000..f866d391a46c
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-4.1.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-4.1.7.ebuild,v 1.1 2014/10/31 08:55:50 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/i18n-0.6.9:0.6
+ >=dev-ruby/json-1.7.7:0
+ >=dev-ruby/tzinfo-1.1:1
+ >=dev-ruby/minitest-5.1:5
+ >=dev-ruby/thread_safe-0.1:0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/libxml-2.0.0
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Avoid test that seems to be broken by lack of DST.
+ sed -i -e '369 s:^:#:' test/core_ext/string_ext_test.rb || die
+
+ # Avoid test that fails with Minitest 5.4 since that already defines
+ # a string E in its TestCase.
+ rm test/core_ext/marshal_test.rb || die
+ sed -i -e '/test_const_missing_in_anonymous_modules/askip "gentoo minitest"' test/dependencies_test.rb || die
+}