summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-15 19:37:14 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-15 19:37:14 +0000
commit8f240ba4cb54d55288fc3567b104655ad9d45108 (patch)
treebf8324693ab74d101fd9f43f8b9d33dda476fc9a /dev-ruby/activesupport
parentMarking libXfontcache-1.0.5 ppc64 for bug 294958 (diff)
downloadgentoo-2-8f240ba4cb54d55288fc3567b104655ad9d45108.tar.gz
gentoo-2-8f240ba4cb54d55288fc3567b104655ad9d45108.tar.bz2
gentoo-2-8f240ba4cb54d55288fc3567b104655ad9d45108.zip
Bump to ruby-fakegem, unbundle builder and tzinfo.
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog8
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.5-r1.ebuild29
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index cdd2f4da1796..2c655ee1e389 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.108 2009/11/30 18:06:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.109 2009/12/15 19:37:14 flameeyes Exp $
+
+*activesupport-2.3.5-r1 (15 Dec 2009)
+
+ 15 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +activesupport-2.3.5-r1.ebuild:
+ Bump to ruby-fakegem, unbundle builder and tzinfo.
30 Nov 2009; Raúl Porcel <armin76@gentoo.org> activesupport-2.3.5.ebuild:
ia64/sparc stable wrt #294797
diff --git a/dev-ruby/activesupport/activesupport-2.3.5-r1.ebuild b/dev-ruby/activesupport/activesupport-2.3.5-r1.ebuild
new file mode 100644
index 000000000000..1e6a3f0ca4a2
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.5-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.5-r1.ebuild,v 1.1 2009/12/15 19:37:14 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2 >=dev-ruby/tzinfo-0.3.12"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder}-* \
+ || die "failed to remove vendor packages"
+}