summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-05 03:27:13 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-05 03:27:13 +0000
commit62f1fe691aac010a601540fa51c2656bf486101e (patch)
tree094204867066e31a6bb7965389f30ba3318073b8 /dev-ruby/archive-tar-minitar
parentInitial version, dependency for pry-debugger. (diff)
downloadgentoo-2-62f1fe691aac010a601540fa51c2656bf486101e.tar.gz
gentoo-2-62f1fe691aac010a601540fa51c2656bf486101e.tar.bz2
gentoo-2-62f1fe691aac010a601540fa51c2656bf486101e.zip
Add ruby20 support. Tests still broken, but no difference to ruby19.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/archive-tar-minitar')
-rw-r--r--dev-ruby/archive-tar-minitar/ChangeLog8
-rw-r--r--dev-ruby/archive-tar-minitar/archive-tar-minitar-0.5.4-r1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/archive-tar-minitar/ChangeLog b/dev-ruby/archive-tar-minitar/ChangeLog
index 570bf5bc6ca1..aec601422b35 100644
--- a/dev-ruby/archive-tar-minitar/ChangeLog
+++ b/dev-ruby/archive-tar-minitar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/archive-tar-minitar
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/archive-tar-minitar/ChangeLog,v 1.50 2013/09/04 13:34:05 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/archive-tar-minitar/ChangeLog,v 1.51 2013/11/05 03:27:13 mrueg Exp $
+
+*archive-tar-minitar-0.5.4-r1 (05 Nov 2013)
+
+ 05 Nov 2013; Manuel Rüger <mrueg@gentoo.org>
+ +archive-tar-minitar-0.5.4-r1.ebuild:
+ Add ruby20 support. Tests still broken, but no difference to ruby19.
04 Sep 2013; Manuel Rüger <mrueg@gentoo.org>
-archive-tar-minitar-0.5.2-r2.ebuild:
diff --git a/dev-ruby/archive-tar-minitar/archive-tar-minitar-0.5.4-r1.ebuild b/dev-ruby/archive-tar-minitar/archive-tar-minitar-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..9d094e634919
--- /dev/null
+++ b/dev-ruby/archive-tar-minitar/archive-tar-minitar-0.5.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/archive-tar-minitar/archive-tar-minitar-0.5.4-r1.ebuild,v 1.1 2013/11/05 03:27:13 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+
+# We don't use RUBY_FAKEGEM_NAME here since for now we want to keep the
+# same gem name.
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides POSIX tarchive management from Ruby programs."
+HOMEPAGE="http://rubyforge.org/projects/ruwiki/"
+SRC_URI="mirror://rubygems/minitar-${PV}.gem"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Tests are broken but this was already the case with 0.5.2 and it seems
+# that only the test case is broken:
+# https://github.com/halostatue/minitar/issues/9
+#RESTRICT="test"
+
+RUBY_PATCHES=(
+ ${PN}-0.5.2-gentoo.patch
+ ${PN}-0.5.3-pipes.patch
+)
+
+all_ruby_prepare() {
+ # ignore faulty metadata
+ rm ../metadata || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Itests -Ctests testall.rb || die
+}