summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-04 11:12:58 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-04 11:12:58 +0000
commit021ca9b4254aa8b95e25946bd7cc7ceec5550545 (patch)
treed2e9736e8740573c1b702e1c93f85ee190d41e72 /dev-ruby/arel
parentRevision bump adds upstream patch to improve perfomance on resource identific... (diff)
downloadgentoo-2-021ca9b4254aa8b95e25946bd7cc7ceec5550545.tar.gz
gentoo-2-021ca9b4254aa8b95e25946bd7cc7ceec5550545.tar.bz2
gentoo-2-021ca9b4254aa8b95e25946bd7cc7ceec5550545.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/arel')
-rw-r--r--dev-ruby/arel/ChangeLog7
-rw-r--r--dev-ruby/arel/arel-2.2.3.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/arel/ChangeLog b/dev-ruby/arel/ChangeLog
index 8c20be948a97..90736abbe3fb 100644
--- a/dev-ruby/arel/ChangeLog
+++ b/dev-ruby/arel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/arel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/arel/ChangeLog,v 1.24 2012/04/01 18:09:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/arel/ChangeLog,v 1.25 2012/04/04 11:12:58 graaff Exp $
+
+*arel-2.2.3 (04 Apr 2012)
+
+ 04 Apr 2012; Hans de Graaff <graaff@gentoo.org> +arel-2.2.3.ebuild:
+ Version bump.
*arel-3.0.2 (01 Apr 2012)
diff --git a/dev-ruby/arel/arel-2.2.3.ebuild b/dev-ruby/arel/arel-2.2.3.ebuild
new file mode 100644
index 000000000000..62bb3a9bcada
--- /dev/null
+++ b/dev-ruby/arel/arel-2.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/arel/arel-2.2.3.ebuild,v 1.1 2012/04/04 11:12:58 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.markdown"
+
+# Generating the gemspec from metadata causes a crash in jruby
+RUBY_FAKEGEM_GEMSPEC="arel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Arel is a Relational Algebra for Ruby."
+HOMEPAGE="http://github.com/rails/arel"
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/hoe-2.10 )
+ test? (
+ >=dev-ruby/hoe-2.10
+ virtual/ruby-minitest
+ )"