summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-10 15:33:02 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-10 15:33:02 +0000
commitf902f69581b9476dab3ccdd7b7743e5181c12ced (patch)
tree1abd2282c69f9bfe66218419c4aa2261eb6a7684 /dev-ruby/awesome_print
parentChange virtual/ffmpeg depend to >=media-video/libav-0.8_pre20111116 as ffmpeg... (diff)
downloadgentoo-2-f902f69581b9476dab3ccdd7b7743e5181c12ced.tar.gz
gentoo-2-f902f69581b9476dab3ccdd7b7743e5181c12ced.tar.bz2
gentoo-2-f902f69581b9476dab3ccdd7b7743e5181c12ced.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/awesome_print')
-rw-r--r--dev-ruby/awesome_print/ChangeLog7
-rw-r--r--dev-ruby/awesome_print/awesome_print-1.0.1.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-ruby/awesome_print/ChangeLog b/dev-ruby/awesome_print/ChangeLog
index 13ebb0eddb85..d41f80fc7967 100644
--- a/dev-ruby/awesome_print/ChangeLog
+++ b/dev-ruby/awesome_print/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/awesome_print
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/awesome_print/ChangeLog,v 1.6 2011/06/28 23:25:16 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/awesome_print/ChangeLog,v 1.7 2011/12/10 15:33:02 graaff Exp $
+
+*awesome_print-1.0.1 (10 Dec 2011)
+
+ 10 Dec 2011; Hans de Graaff <graaff@gentoo.org> +awesome_print-1.0.1.ebuild:
+ Version bump.
28 Jun 2011; MATSUU Takuto <matsuu@gentoo.org> awesome_print-0.4.0.ebuild:
Added ruby19 to USE_RUBY. Added ~x86 to KEYWORDS.
diff --git a/dev-ruby/awesome_print/awesome_print-1.0.1.ebuild b/dev-ruby/awesome_print/awesome_print-1.0.1.ebuild
new file mode 100644
index 000000000000..d5ce58268c52
--- /dev/null
+++ b/dev-ruby/awesome_print/awesome_print-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/awesome_print/awesome_print-1.0.1.ebuild,v 1.1 2011/12/10 15:33:02 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library that pretty prints Ruby objects in full color with proper indentation."
+HOMEPAGE="http://github.com/michaeldv/awesome_print"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 )"
+
+each_ruby_test() {
+ ${RUBY} -S rspec spec || die
+}