summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-29 09:55:48 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-29 09:55:48 +0000
commitf92b3cbb4be20e81fc00e234e0dd094530c29893 (patch)
tree1f1ea6ae3675a7df858f500575bfd9167619bad2 /dev-ruby/bcat/bcat-0.6.2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-f92b3cbb4be20e81fc00e234e0dd094530c29893.tar.gz
gentoo-2-f92b3cbb4be20e81fc00e234e0dd094530c29893.tar.bz2
gentoo-2-f92b3cbb4be20e81fc00e234e0dd094530c29893.zip
Add ruby19. Fix tests.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/bcat/bcat-0.6.2.ebuild')
-rw-r--r--dev-ruby/bcat/bcat-0.6.2.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/dev-ruby/bcat/bcat-0.6.2.ebuild b/dev-ruby/bcat/bcat-0.6.2.ebuild
index d042db2e6d62..527c0a9924bf 100644
--- a/dev-ruby/bcat/bcat-0.6.2.ebuild
+++ b/dev-ruby/bcat/bcat-0.6.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcat/bcat-0.6.2.ebuild,v 1.1 2011/09/11 05:51:27 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcat/bcat-0.6.2.ebuild,v 1.2 2012/01/29 09:55:48 graaff Exp $
EAPI=4
-USE_RUBY="ruby18 ree18"
+USE_RUBY="ruby18 ruby19 ree18"
RUBY_FAKEGEM_TASK_DOC="man"
RUBY_FAKEGEM_EXTRADOC="README"
@@ -23,6 +23,17 @@ ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
ruby_add_rdepend "dev-ruby/rack"
+each_ruby_prepare() {
+ sed -i -e "s/a2h/#{ENV['RUBY']} -S a2h/" test/test_bcat_a2h.rb || die
+}
+
+each_ruby_test() {
+ # The Rakefile uses weird trickery with load path that causes gems
+ # not to be found. Run tests directly instead and do the trickery
+ # here to support popen calls for the bins in this package.
+ RUBY=${RUBY} RUBYLIB=lib:${RUBYLIB} PATH=bin:${PATH} ${RUBY} -S testrb test/test_*.rb || die
+}
+
all_ruby_install() {
all_fakegem_install