summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-24 14:49:02 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-24 14:49:02 +0000
commitd108a802defca19cd3414b69da2e804a28d3e465 (patch)
tree0830f45034a30a3aef9b72006364d095ffe59958 /dev-ruby/bcrypt-ruby
parentVersion bump. (diff)
downloadgentoo-2-d108a802defca19cd3414b69da2e804a28d3e465.tar.gz
gentoo-2-d108a802defca19cd3414b69da2e804a28d3e465.tar.bz2
gentoo-2-d108a802defca19cd3414b69da2e804a28d3e465.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/bcrypt-ruby')
-rw-r--r--dev-ruby/bcrypt-ruby/ChangeLog7
-rw-r--r--dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.9.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-ruby/bcrypt-ruby/ChangeLog b/dev-ruby/bcrypt-ruby/ChangeLog
index ae7896390e33..5432ffb7e55b 100644
--- a/dev-ruby/bcrypt-ruby/ChangeLog
+++ b/dev-ruby/bcrypt-ruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bcrypt-ruby
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcrypt-ruby/ChangeLog,v 1.23 2014/08/05 16:00:27 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcrypt-ruby/ChangeLog,v 1.24 2014/10/24 14:49:02 mrueg Exp $
+
+*bcrypt-ruby-3.1.9 (24 Oct 2014)
+
+ 24 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +bcrypt-ruby-3.1.9.ebuild:
+ Version bump.
05 Aug 2014; Manuel Rüger <mrueg@gentoo.org> bcrypt-ruby-3.1.7.ebuild:
Remove trailing '.' from DESCRIPTION.
diff --git a/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.9.ebuild b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.9.ebuild
new file mode 100644
index 000000000000..5287fbc348dc
--- /dev/null
+++ b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.9.ebuild,v 1.1 2014/10/24 14:49:02 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_NAME="bcrypt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An easy way to keep your users' passwords secure"
+HOMEPAGE="https://github.com/codahale/bcrypt-ruby"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/git ls-files/d' bcrypt.gemspec || die
+ # Fix tests until RSpec3 is available
+ sed -i -e 's/truthy/true/' -e 's/falsey/false/' spec/bcrypt/password_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/mri extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/mri V=1
+ cp ext/mri/*$(get_modname) lib/ || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # bcrypt was called bcrypt-ruby before, so add a spec file that
+ # simply loads bcrypt to make sure that old projects load correctly
+ # we don't even need to create a file to load this: the `require
+ # bcrypt` was already part of bcrypt-ruby requirements.
+ cat - <<EOF > "${T}/bcrypt-ruby.gemspec"
+Gem::Specification.new do |s|
+ s.name = "bcrypt-ruby"
+ s.version = "${RUBY_FAKEGEM_VERSION}"
+ s.summary = "Fake gem to load bcrypt"
+ s.homepage = "${HOMEPAGE}"
+ s.specification_version = 3
+ s.add_runtime_dependency("${RUBY_FAKEGEM_NAME}", ["= ${RUBY_FAKEGEM_VERSION}"])
+end
+EOF
+ RUBY_FAKEGEM_NAME=bcrypt-ruby \
+ RUBY_FAKEGEM_GEMSPEC="${T}/bcrypt-ruby.gemspec" \
+ ruby_fakegem_install_gemspec
+}