summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-05-03 19:49:24 +0000
committerHans de Graaff <graaff@gentoo.org>2015-05-03 19:49:24 +0000
commitcf32a875015ae5fbd02d3b1dabf33b01ee4bcc82 (patch)
tree5abe88c92dabb4d709e4d79fce4f0be27d1f26b5 /dev-ruby/bundler
parentVersion bump. (diff)
downloadgentoo-2-cf32a875015ae5fbd02d3b1dabf33b01ee4bcc82.tar.gz
gentoo-2-cf32a875015ae5fbd02d3b1dabf33b01ee4bcc82.tar.bz2
gentoo-2-cf32a875015ae5fbd02d3b1dabf33b01ee4bcc82.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/bundler')
-rw-r--r--dev-ruby/bundler/ChangeLog7
-rw-r--r--dev-ruby/bundler/bundler-1.8.8.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-ruby/bundler/ChangeLog b/dev-ruby/bundler/ChangeLog
index e810ab2ba39c..731b20f05e42 100644
--- a/dev-ruby/bundler/ChangeLog
+++ b/dev-ruby/bundler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bundler
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.84 2015/05/03 11:54:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.85 2015/05/03 19:49:24 graaff Exp $
+
+*bundler-1.8.8 (03 May 2015)
+
+ 03 May 2015; Hans de Graaff <graaff@gentoo.org> +bundler-1.8.8.ebuild:
+ Version bump.
03 May 2015; Jeroen Roovers <jer@gentoo.org> bundler-1.7.3.ebuild:
Stable for PPC64 (bug #542574).
diff --git a/dev-ruby/bundler/bundler-1.8.8.ebuild b/dev-ruby/bundler/bundler-1.8.8.ebuild
new file mode 100644
index 000000000000..2d339242cf1c
--- /dev/null
+++ b/dev-ruby/bundler/bundler-1.8.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-1.8.8.ebuild,v 1.1 2015/05/03 19:49:24 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+#RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md UPGRADING.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="https://github.com/carlhuda/bundler"
+SRC_URI="https://github.com/carlhuda/bundler/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_rdepend virtual/rubygems
+
+# ruby_add_bdepend "test? ( app-text/ronn )"
+
+# The specs require a number of gems to be installed in a temporary
+# directory, but this requires network access. All tests should still
+# pass with network access.
+RESTRICT="test"
+
+RDEPEND+=" dev-vcs/git"
+
+all_ruby_prepare() {
+ # Bundler only supports running the specs from git:
+ # http://github.com/carlhuda/bundler/issues/issue/738
+ sed -i -e '/when Bundler is bundled/,/^ end/ s:^:#:' spec/runtime/setup_spec.rb || die
+
+ # Fails randomly and no clear cause can be found. Might be related
+ # to bug 346357. This was broken in previous releases without a
+ # failing spec, so patch out this spec for now since it is not a
+ # regression.
+ sed -i -e '/works when you bundle exec bundle/,/^ end/ s:^:#:' spec/install/deploy_spec.rb || die
+
+ # Remove unneeded git dependency from gemspec, which we need to use
+ # for bug 491826
+ sed -i -e '/files/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs that are not compatible with all rspec versions.
+ sed -e '/has no malformed whitespace/,/^ end/ s:^:#:' \
+ -e '/uses double-quotes consistently/,/^ end/ s:^:#:' \
+ -i spec/quality_spec.rb || die
+
+ # Avoid spec failing with git 2.0.
+ sed -i -e '/on releasing/,/^ end/ s:^:#:' spec/bundler/gem_helper_spec.rb || die
+}