summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-14 08:06:06 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-14 08:06:06 +0000
commit89f953c6fe1206c5af14cc5bfc8b31497341b881 (patch)
tree628a7fd8211297d3e74efb95e6fd3208329c6dd8 /dev-ruby/childprocess/childprocess-0.3.0.ebuild
parentdelete dead funcs (diff)
downloadgentoo-2-89f953c6fe1206c5af14cc5bfc8b31497341b881.tar.gz
gentoo-2-89f953c6fe1206c5af14cc5bfc8b31497341b881.tar.bz2
gentoo-2-89f953c6fe1206c5af14cc5bfc8b31497341b881.zip
Version bump.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/childprocess/childprocess-0.3.0.ebuild')
-rw-r--r--dev-ruby/childprocess/childprocess-0.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/childprocess/childprocess-0.3.0.ebuild b/dev-ruby/childprocess/childprocess-0.3.0.ebuild
new file mode 100644
index 000000000000..f80f12d6088f
--- /dev/null
+++ b/dev-ruby/childprocess/childprocess-0.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/childprocess/childprocess-0.3.0.ebuild,v 1.1 2012/01/14 08:06:06 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="childprocess.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple and reliable solution for controlling external programs running in the background."
+HOMEPAGE="https://github.com/jarib/childprocess"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+ruby_add_rdepend "virtual/ruby-ffi"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ rm Gemfile || die
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+}