summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-05-01 05:44:15 +0000
committerHans de Graaff <graaff@gentoo.org>2013-05-01 05:44:15 +0000
commit2539766752a303d6c621d37099c791bb92a4beba (patch)
tree5e677378a39f8515b8e40ff9dbf933072dcf6235 /dev-ruby/diff-lcs
parentCleanup. (diff)
downloadgentoo-2-2539766752a303d6c621d37099c791bb92a4beba.tar.gz
gentoo-2-2539766752a303d6c621d37099c791bb92a4beba.tar.bz2
gentoo-2-2539766752a303d6c621d37099c791bb92a4beba.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/diff-lcs')
-rw-r--r--dev-ruby/diff-lcs/ChangeLog7
-rw-r--r--dev-ruby/diff-lcs/diff-lcs-1.2.4.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-ruby/diff-lcs/ChangeLog b/dev-ruby/diff-lcs/ChangeLog
index a9ee54c3b752..25e5ff6f865b 100644
--- a/dev-ruby/diff-lcs/ChangeLog
+++ b/dev-ruby/diff-lcs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/diff-lcs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/diff-lcs/ChangeLog,v 1.47 2013/05/01 05:40:58 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/diff-lcs/ChangeLog,v 1.48 2013/05/01 05:44:15 graaff Exp $
+
+*diff-lcs-1.2.4 (01 May 2013)
+
+ 01 May 2013; Hans de Graaff <graaff@gentoo.org> +diff-lcs-1.2.4.ebuild:
+ Version bump.
01 May 2013; Hans de Graaff <graaff@gentoo.org> -diff-lcs-1.1.2-r2.ebuild:
Cleanup.
diff --git a/dev-ruby/diff-lcs/diff-lcs-1.2.4.ebuild b/dev-ruby/diff-lcs/diff-lcs-1.2.4.ebuild
new file mode 100644
index 000000000000..afe8f78e3665
--- /dev/null
+++ b/dev-ruby/diff-lcs/diff-lcs-1.2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/diff-lcs/diff-lcs-1.2.4.ebuild,v 1.1 2013/05/01 05:44:15 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Use the McIlroy-Hunt LCS algorithm to compute differences"
+HOMEPAGE="https://github.com/halostatue/diff-lcs"
+
+LICENSE="|| ( MIT Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.10 )"
+
+all_ruby_prepare() {
+ # Remove unneeded rspec require to avoid rspec with USE=doc.
+ sed -i -e "/require 'rspec'/d" Rakefile || die
+
+ # Remove plugins since we don't need them for USE=doc.
+ sed -i -e "/Hoe.plugin/ s:^:#:" Rakefile || die
+}