summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-25 00:52:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-25 00:52:49 +0000
commit06698067162684f04ac9951b13113d1811a9d125 (patch)
tree88f06e2295cc53ca238acbc07f43240d6d33b851 /dev-ruby/fast_xs/fast_xs-0.8.0.ebuild
parentMake sure to install rails/init.rb otherwise haml would fail to load. (diff)
downloadgentoo-2-06698067162684f04ac9951b13113d1811a9d125.tar.gz
gentoo-2-06698067162684f04ac9951b13113d1811a9d125.tar.bz2
gentoo-2-06698067162684f04ac9951b13113d1811a9d125.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/fast_xs/fast_xs-0.8.0.ebuild')
-rw-r--r--dev-ruby/fast_xs/fast_xs-0.8.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/fast_xs/fast_xs-0.8.0.ebuild b/dev-ruby/fast_xs/fast_xs-0.8.0.ebuild
new file mode 100644
index 000000000000..6494f85656b5
--- /dev/null
+++ b/dev-ruby/fast_xs/fast_xs-0.8.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_xs/fast_xs-0.8.0.ebuild,v 1.1 2012/01/25 00:52:49 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="fast_xs text escaping library ruby bindings."
+HOMEPAGE="http://fast-xs.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.3.2 )"
+ruby_add_bdepend "test? ( >=dev-ruby/hoe-2.3.2 virtual/ruby-test-unit )"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/fast_xs extconf.rb || die "extconf.rb failed"
+ ${RUBY} -Cext/fast_xs_extra extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext/fast_xs CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "make extension failed"
+ cp ext/fast_xs/fast_xs$(get_modname) lib/ || die
+ emake -Cext/fast_xs_extra CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "make extension failed"
+ cp ext/fast_xs_extra/fast_xs_extra$(get_modname) lib/ || die
+}