summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-06 11:36:29 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-06 11:36:29 +0000
commitdd18cdbf5f8b8f0f35963df43497717ed9589255 (patch)
tree674f1a7f6d20a5ee9567249564905b742a6206ca /dev-ruby/fcgi
parentAdd ruby20 target. (diff)
downloadgentoo-2-dd18cdbf5f8b8f0f35963df43497717ed9589255.tar.gz
gentoo-2-dd18cdbf5f8b8f0f35963df43497717ed9589255.tar.bz2
gentoo-2-dd18cdbf5f8b8f0f35963df43497717ed9589255.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/fcgi')
-rw-r--r--dev-ruby/fcgi/ChangeLog7
-rw-r--r--dev-ruby/fcgi/fcgi-0.9.2.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/fcgi/ChangeLog b/dev-ruby/fcgi/ChangeLog
index 7ed182ca9872..4032a31e8bfa 100644
--- a/dev-ruby/fcgi/ChangeLog
+++ b/dev-ruby/fcgi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fcgi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fcgi/ChangeLog,v 1.6 2013/09/23 07:16:33 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fcgi/ChangeLog,v 1.7 2013/10/06 11:36:29 mrueg Exp $
+
+*fcgi-0.9.2.1 (06 Oct 2013)
+
+ 06 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +fcgi-0.9.2.1.ebuild:
+ Version bump.
*fcgi-0.9.2 (23 Sep 2013)
diff --git a/dev-ruby/fcgi/fcgi-0.9.2.1.ebuild b/dev-ruby/fcgi/fcgi-0.9.2.1.ebuild
new file mode 100644
index 000000000000..cd9057e59127
--- /dev/null
+++ b/dev-ruby/fcgi/fcgi-0.9.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fcgi/fcgi-0.9.2.1.ebuild,v 1.1 2013/10/06 11:36:29 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc README.signals"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="FastCGI library for Ruby"
+HOMEPAGE="http://github.com/alphallc/ruby-fcgi-ng"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+LICENSE="Ruby"
+
+DEPEND+=" dev-libs/fcgi"
+RDEPEND+=" dev-libs/fcgi"
+
+IUSE=""
+SLOT="0"
+
+each_ruby_configure() {
+ case ${RUBY} in
+ *ruby18|*ruby19|*ruby20)
+ ${RUBY} -C ext/fcgi extconf.rb || die "extconf failed"
+ ;;
+ esac
+}
+
+each_ruby_compile() {
+ case ${RUBY} in
+ *ruby18|*ruby19|*ruby20)
+ emake V=1 -C ext/fcgi
+ cp ext/fcgi/fcgi$(get_modname) lib || die
+ ;;
+ esac
+}