summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-21 16:51:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-21 16:51:34 +0000
commit9520789c6bc4479f388092532f764d15e09637be (patch)
tree2ad11b2da6e4aade7f181fa193613d444370d70a /dev-ruby/file-tail
parentRemove old (diff)
downloadgentoo-2-9520789c6bc4479f388092532f764d15e09637be.tar.gz
gentoo-2-9520789c6bc4479f388092532f764d15e09637be.tar.bz2
gentoo-2-9520789c6bc4479f388092532f764d15e09637be.zip
Version bump; introduce USE=doc support via rdoc recipe.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/file-tail')
-rw-r--r--dev-ruby/file-tail/ChangeLog7
-rw-r--r--dev-ruby/file-tail/file-tail-1.0.11.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/file-tail/ChangeLog b/dev-ruby/file-tail/ChangeLog
index a5d71ce29496..58f2b76e320e 100644
--- a/dev-ruby/file-tail/ChangeLog
+++ b/dev-ruby/file-tail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/file-tail
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/ChangeLog,v 1.7 2012/08/14 18:34:55 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/ChangeLog,v 1.8 2012/08/21 16:51:34 flameeyes Exp $
+
+*file-tail-1.0.11 (21 Aug 2012)
+
+ 21 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> +file-tail-1.0.11.ebuild:
+ Version bump; introduce USE=doc support via rdoc recipe.
14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Update metadata.xml so that it's the same as most other packages.
diff --git a/dev-ruby/file-tail/file-tail-1.0.11.ebuild b/dev-ruby/file-tail/file-tail-1.0.11.ebuild
new file mode 100644
index 000000000000..4cb931ebdc13
--- /dev/null
+++ b/dev-ruby/file-tail/file-tail-1.0.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/file-tail-1.0.11.ebuild,v 1.1 2012/08/21 16:51:34 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOC_SOURCES="lib README.rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A small ruby library that allows it to 'tail' files in Ruby"
+HOMEPAGE="http://flori.github.com/file-tail"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/tins-0.4.3"
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}