summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-22 09:44:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-22 09:44:24 +0000
commitd5d8533ff537626d8992195cdc4d1892fe9ad6ce (patch)
treeb04e1f01160d695573fca2c790e3180a93b32318 /dev-ruby/fssm/fssm-0.2.8.1.ebuild
parentRemoved blockers on app-emulation/qemu-softmmu (dead 10 months ago) and on ap... (diff)
downloadgentoo-2-d5d8533ff537626d8992195cdc4d1892fe9ad6ce.tar.gz
gentoo-2-d5d8533ff537626d8992195cdc4d1892fe9ad6ce.tar.bz2
gentoo-2-d5d8533ff537626d8992195cdc4d1892fe9ad6ce.zip
Version bump; add rb-inotify dependency to gemspec if using it at all.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/fssm/fssm-0.2.8.1.ebuild')
-rw-r--r--dev-ruby/fssm/fssm-0.2.8.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/fssm/fssm-0.2.8.1.ebuild b/dev-ruby/fssm/fssm-0.2.8.1.ebuild
new file mode 100644
index 000000000000..a6ae1be9710d
--- /dev/null
+++ b/dev-ruby/fssm/fssm-0.2.8.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fssm/fssm-0.2.8.1.ebuild,v 1.1 2012/01/22 09:44:24 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="File System State Monitor API"
+HOMEPAGE="http://github.com/ttilley/fssm"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# rb-inotify is a Linux-specific extension, so we will need to make this
+# conditional when keywords are added that are not linux-specific.
+ruby_add_rdepend "kernel_linux? ( >=dev-ruby/rb-inotify-0.8.6-r1 )"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.4.0:2 )"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die
+ rm Gemfile || die
+
+ # Fix/ignore broken specs with patch from upstream
+ epatch "${FILESDIR}/${PN}-0.2.7-test.patch"
+
+ # if we're going to require rb-inotify, let's make sure it gets used
+ # as well; if we don't declare it in the dependencies this will not
+ # be loaded by bundler-based projects to begin with.
+ if use kernel_linux; then
+ sed -i -e '/^end/i s.add_dependency "rb-inotify"' ${RUBY_FAKEGEM_GEMSPEC} || die
+ fi
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc example.rb
+}