summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-12-27 18:22:07 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-12-27 18:22:07 +0000
commit8a0159f82efabd482dca4415806f987a157596df (patch)
tree94a02cf47b7b3a38dfad0833231eb61595b23c02 /dev-ruby/fxruby
parentnew package. Fixes #12430 (diff)
downloadgentoo-2-8a0159f82efabd482dca4415806f987a157596df.tar.gz
gentoo-2-8a0159f82efabd482dca4415806f987a157596df.tar.bz2
gentoo-2-8a0159f82efabd482dca4415806f987a157596df.zip
new package. Fixes #12723
Diffstat (limited to 'dev-ruby/fxruby')
-rw-r--r--dev-ruby/fxruby/ChangeLog7
-rw-r--r--dev-ruby/fxruby/files/digest-fxruby-1.0.171
-rw-r--r--dev-ruby/fxruby/fxruby-1.0.17.ebuild26
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/fxruby/ChangeLog b/dev-ruby/fxruby/ChangeLog
new file mode 100644
index 000000000000..219c226757dc
--- /dev/null
+++ b/dev-ruby/fxruby/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-ruby/fxruby
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.1 2002/12/27 18:22:07 rphillips Exp $
+
+*fxruby-1.0.17 (27 Dec 2002)
+
+ 27 Dec 2002; Ryan Phillips <rphillips@gentoo.org> : Initial release. Submitted by: Holden Glova
diff --git a/dev-ruby/fxruby/files/digest-fxruby-1.0.17 b/dev-ruby/fxruby/files/digest-fxruby-1.0.17
new file mode 100644
index 000000000000..95ea4a0b331c
--- /dev/null
+++ b/dev-ruby/fxruby/files/digest-fxruby-1.0.17
@@ -0,0 +1 @@
+MD5 fc2cdc23c188b845eb385f9c3eeb946f FXRuby-1.0.17.tar.gz 1199512
diff --git a/dev-ruby/fxruby/fxruby-1.0.17.ebuild b/dev-ruby/fxruby/fxruby-1.0.17.ebuild
new file mode 100644
index 000000000000..3c08e5127119
--- /dev/null
+++ b/dev-ruby/fxruby/fxruby-1.0.17.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.0.17.ebuild,v 1.1 2002/12/27 18:22:07 rphillips Exp $
+
+S=${WORKDIR}/FXRuby-${PV}
+DESCRIPTION="FXRuby is the Ruby language binding to the FOX GUI toolkit."
+SRC_URI="mirror://sourceforge/fxruby/FXRuby-${PV}.tar.gz"
+HOMEPAGE="http://www.fxruby.org"
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-lang/ruby-1.6
+ >=x11-libs/fox-1.0.17"
+
+src_compile() {
+ ruby install.rb config --prefix=${D}/usr || die "Failed to configure FXRuby"
+ ruby install.rb setup || die "Failed to setup FXRuby"
+}
+
+src_install() {
+ ruby install.rb install || die "Failed to install FXRuby"
+
+ dodoc [A-Z]*
+ cp -dr examples doc ${D}/usr/share/doc/${PF}
+}