summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-23 21:46:19 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-23 21:46:19 +0000
commit2d568a500e44e236c46cae6e9550bdb013390a9b (patch)
treee7df285dbc94a502a276b02018be81ea3f8e545a /dev-ruby/i18n
parentDepend on a newer version of Ruby-Inline for correct REE18 support; prebuild ... (diff)
downloadgentoo-2-2d568a500e44e236c46cae6e9550bdb013390a9b.tar.gz
gentoo-2-2d568a500e44e236c46cae6e9550bdb013390a9b.tar.bz2
gentoo-2-2d568a500e44e236c46cae6e9550bdb013390a9b.zip
Update i18n to 0.3.7, add (realistic) REE18 and JRuby support.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/i18n')
-rw-r--r--dev-ruby/i18n/ChangeLog8
-rw-r--r--dev-ruby/i18n/files/i18n-0.3.7-gentoo.patch32
-rw-r--r--dev-ruby/i18n/i18n-0.3.3.ebuild4
-rw-r--r--dev-ruby/i18n/i18n-0.3.7.ebuild69
4 files changed, 110 insertions, 3 deletions
diff --git a/dev-ruby/i18n/ChangeLog b/dev-ruby/i18n/ChangeLog
index 6d8406e6f31e..57f25b5c803c 100644
--- a/dev-ruby/i18n/ChangeLog
+++ b/dev-ruby/i18n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/i18n
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.13 2010/05/23 10:26:58 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.14 2010/05/23 21:46:19 flameeyes Exp $
+
+*i18n-0.3.7 (23 May 2010)
+
+ 23 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> i18n-0.3.3.ebuild,
+ +i18n-0.3.7.ebuild, +files/i18n-0.3.7-gentoo.patch:
+ Update i18n to 0.3.7, add (realistic) REE18 and JRuby support.
23 May 2010; Alex Legler <a3li@gentoo.org> i18n-0.1.3.ebuild:
Add REE18 support
diff --git a/dev-ruby/i18n/files/i18n-0.3.7-gentoo.patch b/dev-ruby/i18n/files/i18n-0.3.7-gentoo.patch
new file mode 100644
index 000000000000..17fd05bf7430
--- /dev/null
+++ b/dev-ruby/i18n/files/i18n-0.3.7-gentoo.patch
@@ -0,0 +1,32 @@
+diff --git a/test/backend/interpolation_compiler_test.rb b/test/backend/interpolation_compiler_test.rb
+index 5051299..5852b9c 100644
+--- a/test/backend/interpolation_compiler_test.rb
++++ b/test/backend/interpolation_compiler_test.rb
+@@ -104,5 +104,5 @@ class I18nBackendInterpolationCompilerTest < Test::Unit::TestCase
+ end
+
+ # I kinda don't think this really is a correct behavior
+- undef :'test interpolation: given no values it does not alter the string'
+-end
+\ No newline at end of file
++ undef_method 'test interpolation: given no values it does not alter the string'
++end
+diff --git a/test/test_setup_requirements.rb b/test/test_setup_requirements.rb
+index d5a2cbe..a057042 100644
+--- a/test/test_setup_requirements.rb
++++ b/test/test_setup_requirements.rb
+@@ -34,6 +34,7 @@ end
+
+ def setup_active_record
+ begin
++ require 'sqlite3'
+ require 'active_record'
+ ActiveRecord::Base.connection
+ true
+@@ -63,4 +64,4 @@ def connect_active_record
+ t.boolean :is_proc, :default => false
+ end
+ end
+-end
+\ No newline at end of file
++end
diff --git a/dev-ruby/i18n/i18n-0.3.3.ebuild b/dev-ruby/i18n/i18n-0.3.3.ebuild
index 584edeb57619..b62e2dbb05f6 100644
--- a/dev-ruby/i18n/i18n-0.3.3.ebuild
+++ b/dev-ruby/i18n/i18n-0.3.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.3.3.ebuild,v 1.7 2010/05/23 10:25:11 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.3.3.ebuild,v 1.8 2010/05/23 21:46:19 flameeyes Exp $
EAPI=2
-USE_RUBY="ruby18 ree18"
+USE_RUBY="ruby18"
RUBY_FAKEGEM_EXTRAINSTALL="vendor"
diff --git a/dev-ruby/i18n/i18n-0.3.7.ebuild b/dev-ruby/i18n/i18n-0.3.7.ebuild
new file mode 100644
index 000000000000..af4df5fd1240
--- /dev/null
+++ b/dev-ruby/i18n/i18n-0.3.7.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.3.7.ebuild,v 1.1 2010/05/23 21:46:19 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 jruby ree18"
+
+# doc regeneration seem to need Jeweler, which is not currently
+# available
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.textile CHANGELOG.textile"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Add Internationalization support to your Ruby application."
+HOMEPAGE="http://rails-i18n.org/"
+
+SRC_URI="http://github.com/svenfuchs/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/svenfuchs-${PN}-*"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# Optionally, the testsuite uses the activerecord gem to run some
+# tests; whent hey run, they require sqlite3-ruby, and that is not
+# available on JRuby.
+USE_RUBY="${USE_RUBY/jruby/}" \
+ ruby_add_bdepend "
+ test? (
+ dev-ruby/activerecord
+ dev-ruby/sqlite3-ruby
+ dev-ruby/ruby2ruby
+ )"
+
+# mocha is optionally used by the testsuite, try to increase coverage
+# of testing by depending on it; when mocha is used, though,
+# test-unit:2 cannot be merged at the same time (mocha problem?)
+#
+# One further test dependency would be ruby-cldr
+# (http://rubygems.org/gems/ruby-cldr) but we don't have it in tree
+# yet.
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ !!dev-ruby/test-unit:2
+ )"
+
+src_compile() {
+ # permissions need to be stricter for Ruby-Inline to work properly.
+ chmod 0755 ${WORKDIR/work/homedir} || die "Failed to fix permissions on home"
+ ruby-ng_src_compile
+}
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_test() {
+ # permissions need to be stricter for Ruby-Inline to work properly.
+ chmod 0755 ${WORKDIR/work/homedir} || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}