summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2012-04-17 15:43:20 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2012-04-17 15:43:20 +0000
commit35b06da270fecea1a3050114e2c63ab3351e701a (patch)
treeedf81cbf2d0845adc6ebe8728f976cb6be717b0f /dev-ruby/iobuffer/iobuffer-1.1.2-r2.ebuild
parenthttp://my.opera.com/desktopteam/blog/2012/04/17/camera-getusermedia-support (diff)
downloadgentoo-2-35b06da270fecea1a3050114e2c63ab3351e701a.tar.gz
gentoo-2-35b06da270fecea1a3050114e2c63ab3351e701a.tar.bz2
gentoo-2-35b06da270fecea1a3050114e2c63ab3351e701a.zip
Fixed src_test issue. Clean up.
(Portage version: 2.1.10.54/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/iobuffer/iobuffer-1.1.2-r2.ebuild')
-rw-r--r--dev-ruby/iobuffer/iobuffer-1.1.2-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/iobuffer/iobuffer-1.1.2-r2.ebuild b/dev-ruby/iobuffer/iobuffer-1.1.2-r2.ebuild
new file mode 100644
index 000000000000..2c36d9684327
--- /dev/null
+++ b/dev-ruby/iobuffer/iobuffer-1.1.2-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/iobuffer/iobuffer-1.1.2-r2.ebuild,v 1.1 2012/04/17 15:43:20 matsuu Exp $
+
+EAPI="4"
+# jruby: mkmf
+# rbx: Kernel(Autoload)#allocate (method_missing)
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+inherit ruby-fakegem
+
+GITHUB_USER="tarcieri"
+
+DESCRIPTION="IO::Buffer is a fast byte queue which is primarily intended for non-blocking I/O applications"
+HOMEPAGE="http://github.com/tarcieri/iobuffer"
+SRC_URI="http://github.com/${GITHUB_USER}/iobuffer/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+SLOT="0"
+IUSE=""
+
+RUBY_S="${GITHUB_USER}-${PN}-*"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/rspec )"
+
+all_ruby_prepare() {
+ rm .rspec lib/.gitignore
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb
+ sed -i -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" ext/Makefile
+}
+
+each_ruby_compile() {
+ emake -C ext
+ cp ext/iobuffer_ext.so lib/
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S rspec spec
+}