summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-08-28 08:16:55 +0000
committerHans de Graaff <graaff@gentoo.org>2010-08-28 08:16:55 +0000
commit6380e46713152d54eacd6fba11d03109b25e1d0f (patch)
treeba98b4cb3789078b2ecef2a468e957fe6f5bc92c /dev-ruby/json
parentadd ~arm, bug #334273 (diff)
downloadgentoo-2-6380e46713152d54eacd6fba11d03109b25e1d0f.tar.gz
gentoo-2-6380e46713152d54eacd6fba11d03109b25e1d0f.tar.bz2
gentoo-2-6380e46713152d54eacd6fba11d03109b25e1d0f.zip
Remove old versions.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/ChangeLog6
-rw-r--r--dev-ruby/json/json-1.2.2.ebuild65
-rw-r--r--dev-ruby/json/json-1.4.3.ebuild65
3 files changed, 5 insertions, 131 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index 884410743ce1..8d1a12e3b745 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.39 2010/08/17 00:28:13 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.40 2010/08/28 08:16:55 graaff Exp $
+
+ 22 Aug 2010; Hans de Graaff <graaff@gentoo.org> -json-1.2.2.ebuild,
+ -json-1.4.3.ebuild:
+ Remove old versions.
17 Aug 2010; Jeroen Roovers <jer@gentoo.org> json-1.4.3-r1.ebuild:
Stable for HPPA (bug #321043).
diff --git a/dev-ruby/json/json-1.2.2.ebuild b/dev-ruby/json/json-1.2.2.ebuild
deleted file mode 100644
index 981a1fe6b258..000000000000
--- a/dev-ruby/json/json-1.2.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.2.2.ebuild,v 1.6 2010/05/24 19:09:49 pacho Exp $
-
-EAPI=2
-USE_RUBY="ruby18"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension."
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-SRC_URI="mirror://rubygems/${P}.gem"
-
-KEYWORDS="amd64 ~hppa ia64 ~ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
- dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake
- test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- sed -i \
- -e 's| => :compile_ext||' \
- -e 's| => :clean||' \
- Rakefile || die "rakefile fix failed"
-}
-
-each_ruby_compile() {
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ${RUBY} -S rake compile_ext || die "extension compile failed"
- fi
-}
-
-each_ruby_test() {
- # We have to set RUBYLIB because otherwise the tests will run
- # against the sytem-installed json; at the same time, we cannot
- # use the -I parameter because rake won't let it pass to the
- # testrb call that is executed down the road.
-
- RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
- ${RUBY} -S rake test_pure || die "pure ruby tests failed"
-
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
- ${RUBY} -Ilib:ext/json/ext -S rake test_ext || die " ruby extension tests failed"
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ruby_fakegem_newins ext/json/ext/generator.so lib/json/generator.so
- ruby_fakegem_newins ext/json/ext/parser.so lib/json/parser.so
- fi
-}
diff --git a/dev-ruby/json/json-1.4.3.ebuild b/dev-ruby/json/json-1.4.3.ebuild
deleted file mode 100644
index 7b72d0a91003..000000000000
--- a/dev-ruby/json/json-1.4.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.4.3.ebuild,v 1.3 2010/05/22 22:54:33 a3li Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension."
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-SRC_URI="mirror://rubygems/${P}.gem"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
- dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake
- test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- sed -i \
- -e 's| => :compile_ext||' \
- -e 's| => :clean||' \
- Rakefile || die "rakefile fix failed"
-}
-
-each_ruby_compile() {
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ${RUBY} -S rake compile_ext || die "extension compile failed"
- fi
-}
-
-each_ruby_test() {
- # We have to set RUBYLIB because otherwise the tests will run
- # against the sytem-installed json; at the same time, we cannot
- # use the -I parameter because rake won't let it pass to the
- # testrb call that is executed down the road.
-
- RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
- ${RUBY} -S rake test_pure || die "pure ruby tests failed"
-
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
- ${RUBY} -Ilib:ext/json/ext -S rake test_ext || die " ruby extension tests failed"
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ruby_fakegem_newins ext/json/ext/generator.so lib/json/generator.so
- ruby_fakegem_newins ext/json/ext/parser.so lib/json/parser.so
- fi
-}