summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-09-12 06:22:18 +0000
committerHans de Graaff <graaff@gentoo.org>2013-09-12 06:22:18 +0000
commit3e96db6a788776bfdd7193cce6f1b6569817c106 (patch)
treea1197dd0b6b6b87ee17ae0c83cb53c02f4c1c8bb /dev-ruby/maruku
parentldap is not required in required_use (diff)
downloadgentoo-2-3e96db6a788776bfdd7193cce6f1b6569817c106.tar.gz
gentoo-2-3e96db6a788776bfdd7193cce6f1b6569817c106.tar.bz2
gentoo-2-3e96db6a788776bfdd7193cce6f1b6569817c106.zip
Revision bump to add ruby20, needed for bootstrapping yard.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/maruku')
-rw-r--r--dev-ruby/maruku/ChangeLog7
-rw-r--r--dev-ruby/maruku/maruku-0.6.1-r1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-ruby/maruku/ChangeLog b/dev-ruby/maruku/ChangeLog
index 96dd61822eac..9aa738c6dcad 100644
--- a/dev-ruby/maruku/ChangeLog
+++ b/dev-ruby/maruku/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/maruku
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/maruku/ChangeLog,v 1.26 2013/09/04 11:44:36 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/maruku/ChangeLog,v 1.27 2013/09/12 06:22:18 graaff Exp $
+
+*maruku-0.6.1-r1 (12 Sep 2013)
+
+ 12 Sep 2013; Hans de Graaff <graaff@gentoo.org> +maruku-0.6.1-r1.ebuild:
+ Revision bump to add ruby20, needed for bootstrapping yard.
04 Sep 2013; Manuel Rüger <mrueg@gentoo.org> -maruku-0.6.0-r2.ebuild:
Cleanup old.
diff --git a/dev-ruby/maruku/maruku-0.6.1-r1.ebuild b/dev-ruby/maruku/maruku-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..6d3f56cb6185
--- /dev/null
+++ b/dev-ruby/maruku/maruku-0.6.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/maruku/maruku-0.6.1-r1.ebuild,v 1.1 2013/09/12 06:22:18 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="docs/changelog.md docs/div_syntax.md docs/entity_test.md
+ docs/markdown_syntax.md docs/maruku.md docs/math.md docs/other_stuff.md
+ docs/proposal.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Markdown-superset interpreter written in Ruby."
+HOMEPAGE="http://maruku.rubyforge.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend dev-ruby/syntax
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/Gem::manage_gems/s:^:#:' \
+ -e '/jamis\.rb/s:^:#:' \
+ Rakefile
+}
+
+each_ruby_test() {
+ # Unit tests fail in various ways. Skip them for now since we never ran
+ # tests for earlier versions at all. No clear upstream to report to...
+ # ${RUBY} -Ilib bin/marutest $(find tests/unittest -name '*.md') || die
+ ${RUBY} -Ilib lib/maruku/tests/new_parser.rb v b || die
+}
+
+pkg_postinst() {
+ elog
+ elog "You need to emerge app-text/texlive and dev-tex/latex-unicode if"
+ elog "you want to use --pdf with Maruku. You may also want to emerge"
+ elog "dev-tex/listings to enable LaTeX syntax highlighting."
+ elog
+}