summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 01:15:23 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 01:15:23 +0000
commitf2c1d011f440a5572cba6c129fbbfbad3862adfa (patch)
treed824b580d5030f393858f782e14037af78244575 /dev-ruby/matchy
parentInitial import of bundler, that might not be too nice for us but it's still a... (diff)
downloadgentoo-2-f2c1d011f440a5572cba6c129fbbfbad3862adfa.tar.gz
gentoo-2-f2c1d011f440a5572cba6c129fbbfbad3862adfa.tar.bz2
gentoo-2-f2c1d011f440a5572cba6c129fbbfbad3862adfa.zip
Initial import of (mcmire-)matchy, needed for crack's testsuite.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/matchy')
-rw-r--r--dev-ruby/matchy/ChangeLog10
-rw-r--r--dev-ruby/matchy/files/matchy-0.4.2-order.patch20
-rw-r--r--dev-ruby/matchy/matchy-0.4.2.ebuild35
-rw-r--r--dev-ruby/matchy/metadata.xml5
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-ruby/matchy/ChangeLog b/dev-ruby/matchy/ChangeLog
new file mode 100644
index 000000000000..a01b9ad29f4e
--- /dev/null
+++ b/dev-ruby/matchy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/matchy
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/matchy/ChangeLog,v 1.1 2010/01/28 01:15:22 flameeyes Exp $
+
+*matchy-0.4.2 (28 Jan 2010)
+
+ 28 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +matchy-0.4.2.ebuild, +files/matchy-0.4.2-order.patch, +metadata.xml:
+ Initial import of (mcmire-)matchy, needed for crack's testsuite.
+
diff --git a/dev-ruby/matchy/files/matchy-0.4.2-order.patch b/dev-ruby/matchy/files/matchy-0.4.2-order.patch
new file mode 100644
index 000000000000..5550c892b2e3
--- /dev/null
+++ b/dev-ruby/matchy/files/matchy-0.4.2-order.patch
@@ -0,0 +1,20 @@
+Index: matchy-0.4.2/test/test_operator_expectations.rb
+===================================================================
+--- matchy-0.4.2.orig/test/test_operator_expectations.rb
++++ matchy-0.4.2/test/test_operator_expectations.rb
+@@ -156,12 +156,13 @@ class TestOperatorExpectations < Test::U
+ end
+
+ def test_fail_message_for_hash
+- obj = Matchy::Expectations::OperatorExpectation.new({:foo => 'bar', :baz => 'quux'}, true)
++ hash = {:foo => 'bar', :baz => 'quux'}
++ obj = Matchy::Expectations::OperatorExpectation.new(hash, true)
+
+ def obj.flunk(msg)
+ msg
+ end
+
+- (obj == {:foo => 'bar'}).should == "Expected {:baz=>\"quux\", :foo=>\"bar\"} to == {:foo=>\"bar\"} (diff: {:baz=>\"quux\"})."
++ (obj == {:foo => 'bar'}).should == "Expected #{hash.inspect} to == {:foo=>\"bar\"} (diff: {:baz=>\"quux\"})."
+ end
+ end
diff --git a/dev-ruby/matchy/matchy-0.4.2.ebuild b/dev-ruby/matchy/matchy-0.4.2.ebuild
new file mode 100644
index 000000000000..48578a173859
--- /dev/null
+++ b/dev-ruby/matchy/matchy-0.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/matchy/matchy-0.4.2.ebuild,v 1.1 2010/01/28 01:15:22 flameeyes Exp $
+
+EAPI="2"
+
+MY_OWNER="mcmire"
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC=""
+
+RUBY_FAKEGEM_NAME="${MY_OWNER}-${PN}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec-esque matchers for use in Test::Unit"
+HOMEPAGE="http://github.com/mcmire/matchy"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ # Don't force us to use Jeweler, disable check_dependency task
+ # dependency.
+ sed -i \
+ -e '/check_dependencies/s:^:#:' \
+ Rakefile || die
+
+ # ordering problem, sent upstream
+ epatch "${FILESDIR}"/${P}-order.patch
+}
diff --git a/dev-ruby/matchy/metadata.xml b/dev-ruby/matchy/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/matchy/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>