summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-14 07:41:19 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-14 07:41:19 +0000
commitae68dfc1fac033a4fdc040551e2d9363dc47b3a6 (patch)
treeb4632138f569cbc40b5efa92330d03c5e5f99fa1 /dev-ruby/mini_magick
parentVersion bump. (diff)
downloadgentoo-2-ae68dfc1fac033a4fdc040551e2d9363dc47b3a6.tar.gz
gentoo-2-ae68dfc1fac033a4fdc040551e2d9363dc47b3a6.tar.bz2
gentoo-2-ae68dfc1fac033a4fdc040551e2d9363dc47b3a6.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/mini_magick')
-rw-r--r--dev-ruby/mini_magick/ChangeLog7
-rw-r--r--dev-ruby/mini_magick/mini_magick-3.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/mini_magick/ChangeLog b/dev-ruby/mini_magick/ChangeLog
index ea9e2f88966e..a5e17a581ae0 100644
--- a/dev-ruby/mini_magick/ChangeLog
+++ b/dev-ruby/mini_magick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/mini_magick
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/ChangeLog,v 1.7 2011/01/02 13:04:53 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/ChangeLog,v 1.8 2011/01/14 07:41:19 graaff Exp $
+
+*mini_magick-3.2 (14 Jan 2011)
+
+ 14 Jan 2011; Hans de Graaff <graaff@gentoo.org> +mini_magick-3.2.ebuild:
+ Version bump.
*mini_magick-3.1 (02 Jan 2011)
diff --git a/dev-ruby/mini_magick/mini_magick-3.2.ebuild b/dev-ruby/mini_magick/mini_magick-3.2.ebuild
new file mode 100644
index 000000000000..3e6f575f9450
--- /dev/null
+++ b/dev-ruby/mini_magick/mini_magick-3.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/mini_magick-3.2.ebuild,v 1.1 2011/01/14 07:41:19 graaff Exp $
+
+EAPI=2
+
+# jruby → test_tempfile_at_path_after_format fails with jruby 1.3.1,
+# sounds like a bug in JRuby itself, or the code not being compatible.
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Manipulate images with minimal use of memory."
+HOMEPAGE="http://github.com/probablycorey/mini_magick"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# It's only used at runtime in this case because this extension only
+# _calls_ the commands. But when we run tests we're going to need tiff
+# and jpeg support at a minimum.
+RDEPEND="media-gfx/imagemagick"
+DEPEND="test? ( media-gfx/imagemagick[tiff,jpeg] )"
+
+# tests are known to fail under imagemagick 6.5 at least, reported upstream:
+# http://github.com/probablycorey/mini_magick/issues/#issue/2
+# update: still fails with imagemagick 6.6.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+ruby_add_rdepend ">=dev-ruby/subexec-0.0.4"
+
+all_ruby_prepare() {
+ # remove executable bit from all files
+ find "${S}" -type f -exec chmod -x {} +
+
+ # Remove spec definition part because the gemspec file is not included
+ sed -i -e '/gemspec/,$ d' Rakefile || die
+}