summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-11-20 12:49:52 +0000
committerHans de Graaff <graaff@gentoo.org>2011-11-20 12:49:52 +0000
commita8d81d808012f201c264c2d6dcbe3307c34b0f7d (patch)
tree2f2c530b79d90c45de635da47cfa55cc84a2c04a /dev-ruby/minitest/minitest-2.8.1.ebuild
parentDrop DEPRECATED flags, bug #391105 (diff)
downloadgentoo-2-a8d81d808012f201c264c2d6dcbe3307c34b0f7d.tar.gz
gentoo-2-a8d81d808012f201c264c2d6dcbe3307c34b0f7d.tar.bz2
gentoo-2-a8d81d808012f201c264c2d6dcbe3307c34b0f7d.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/minitest/minitest-2.8.1.ebuild')
-rw-r--r--dev-ruby/minitest/minitest-2.8.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/minitest/minitest-2.8.1.ebuild b/dev-ruby/minitest/minitest-2.8.1.ebuild
new file mode 100644
index 000000000000..787e377c14fb
--- /dev/null
+++ b/dev-ruby/minitest/minitest-2.8.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-2.8.1.ebuild,v 1.1 2011/11/20 12:49:52 graaff Exp $
+
+EAPI=2
+# jruby → tests fail, reported upstream
+# http://rubyforge.org/tracker/index.php?func=detail&aid=27657&group_id=1040&atid=4097
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="minitest/unit is a small and fast replacement for ruby's huge and slow test/unit."
+HOMEPAGE="http://rubyforge.org/projects/bfts"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/hoe dev-ruby/rdoc )
+ test? (
+ dev-ruby/rdoc
+ dev-ruby/hoe
+ )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Remove failing tests. Upstream claims that these are all
+ # bugs in jruby. By removing the failing tests we can at
+ # least run the remainder. See bug 321055 for details.
+ rm -f test/test_minitest_unit.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}