summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-13 20:50:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-13 20:50:01 +0000
commitc80fe86dcadea6a222008d8ff168f72c2ec320e5 (patch)
treebade1e0e0ad44ee7a2e2c77b659ca761a3d92829 /dev-ruby/mixlib-config
parentStable ppc64, bug #431206 (diff)
downloadgentoo-2-c80fe86dcadea6a222008d8ff168f72c2ec320e5.tar.gz
gentoo-2-c80fe86dcadea6a222008d8ff168f72c2ec320e5.tar.bz2
gentoo-2-c80fe86dcadea6a222008d8ff168f72c2ec320e5.zip
Use the rspec helper for tests; add missing test USE flag and disable rake dependency; add ree18.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/mixlib-config')
-rw-r--r--dev-ruby/mixlib-config/ChangeLog8
-rw-r--r--dev-ruby/mixlib-config/mixlib-config-1.1.2.ebuild10
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-ruby/mixlib-config/ChangeLog b/dev-ruby/mixlib-config/ChangeLog
index b1e93aaaa65b..3766441fd0b3 100644
--- a/dev-ruby/mixlib-config/ChangeLog
+++ b/dev-ruby/mixlib-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/mixlib-config
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-config/ChangeLog,v 1.3 2012/08/11 08:34:29 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-config/ChangeLog,v 1.4 2012/08/13 20:50:01 flameeyes Exp $
+
+ 13 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ mixlib-config-1.1.2.ebuild:
+ Use the rspec helper for tests; add missing test USE flag and disable rake
+ dependency; add ree18.
11 Aug 2012; Benedikt Böhm <hollow@gentoo.org> mixlib-config-1.1.2.ebuild:
add ruby19 support; migrate to EAPI4 and rspec2
@@ -13,4 +18,3 @@
03 Jul 2010; Benedikt Böhm <hollow@gentoo.org>
+mixlib-config-1.1.2.ebuild, +metadata.xml:
initial ebuild, thanks to Gábor Vészi
-
diff --git a/dev-ruby/mixlib-config/mixlib-config-1.1.2.ebuild b/dev-ruby/mixlib-config/mixlib-config-1.1.2.ebuild
index e64319b513ce..11764bdaa671 100644
--- a/dev-ruby/mixlib-config/mixlib-config-1.1.2.ebuild
+++ b/dev-ruby/mixlib-config/mixlib-config-1.1.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-config/mixlib-config-1.1.2.ebuild,v 1.3 2012/08/11 08:34:29 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-config/mixlib-config-1.1.2.ebuild,v 1.4 2012/08/13 20:50:01 flameeyes Exp $
EAPI=4
-USE_RUBY="ruby18 ruby19"
+USE_RUBY="ruby18 ruby19 ree18"
RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_RECIPE_TEST="none"
RUBY_FAKEGEM_EXTRADOC="NOTICE README.rdoc"
@@ -20,7 +20,7 @@ RUBY_S="opscode-${PN}-*"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE=""
+IUSE="test"
ruby_add_bdepend "test? (
dev-ruby/rspec:2
@@ -28,6 +28,6 @@ ruby_add_bdepend "test? (
)"
each_ruby_test() {
- ${RUBY} -S rspec spec || die
+ ruby-ng_rspec
${RUBY} -S cucumber features || die
}