summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-21 18:12:39 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-21 18:12:39 +0000
commit1ade7d48e194ce7a73c4c8d43ccff79e87ac7dea (patch)
tree0115707d5c755b1fcd6499910ac107f048c806e5 /dev-ruby/mod_ruby/mod_ruby-1.2.2.ebuild
parentnow builds from source (Manifest recommit) (diff)
downloadgentoo-2-1ade7d48e194ce7a73c4c8d43ccff79e87ac7dea.tar.gz
gentoo-2-1ade7d48e194ce7a73c4c8d43ccff79e87ac7dea.tar.bz2
gentoo-2-1ade7d48e194ce7a73c4c8d43ccff79e87ac7dea.zip
Renamed from mod-ruby.
Diffstat (limited to 'dev-ruby/mod_ruby/mod_ruby-1.2.2.ebuild')
-rw-r--r--dev-ruby/mod_ruby/mod_ruby-1.2.2.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/dev-ruby/mod_ruby/mod_ruby-1.2.2.ebuild b/dev-ruby/mod_ruby/mod_ruby-1.2.2.ebuild
new file mode 100644
index 000000000000..c96e71a25c89
--- /dev/null
+++ b/dev-ruby/mod_ruby/mod_ruby-1.2.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod_ruby/mod_ruby-1.2.2.ebuild,v 1.1 2004/09/21 18:12:39 usata Exp $
+
+DESCRIPTION="Embeds the Ruby interpreter into Apache"
+HOMEPAGE="http://modruby.net/"
+SRC_URI="http://modruby.net/archive/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+# 1.2.X -> stable branch; 1.3.Y -> development branch
+KEYWORDS="alpha ~sparc x86 ~ppc"
+IUSE="apache2 doc"
+DEPEND=">=net-www/apache-1.3.3
+ virtual/ruby
+ doc? ( dev-ruby/rdtool )"
+
+apache2-detect() {
+ use apache2 || ! has_version '=net-www/apache-1*'
+}
+
+src_compile() {
+
+ local two
+ if apache2-detect ; then
+ two="2"
+ else # apache1
+ ewarn "apache 1.3.x support is UNTESTED"
+ two=""
+ fi
+
+ ./configure.rb --with-apxs=/usr/sbin/apxs${two}
+
+ sed -i -e "s:\(^APACHE_LIBEXECDIR = \$(DESTDIR)/usr/lib/apache${two}\)/modules:\1-extramodules:" Makefile
+
+ emake || die
+
+ if use doc; then
+ cd doc
+ emake
+ fi
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ if apache2-detect ; then
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/20_mod_ruby.conf
+ else # apache1
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_ruby.conf
+ fi
+
+ dodoc ChangeLog COPYING README.*
+
+ if use doc; then
+ dohtml doc/*.css doc/*.html
+ fi
+
+}
+
+pkg_postinst() {
+ if apache2-detect ; then
+ einfo "To enable mod_ruby, edit /etc/conf.d/apache2 and add \"-D RUBY\""
+ einfo "You may also wish to edit /etc/apache2/conf/modules.d/20_mod_ruby.conf"
+ else # apache1
+ einfo "To enable mod_ruby:"
+ einfo "1. Run \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D RUBY\""
+ fi
+ einfo "You must restart apache for changes to take effect"
+}
+
+pkg_config() {
+ if ! apache2-detect ; then
+ echo -e "<IfDefine RUBY>\n Include conf/addon-modules/mod_ruby.conf\n</IfDefine>" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+ fi
+}