summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-08-19 20:43:42 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-08-19 20:43:42 +0000
commit27a3158f0f92bbb34e84705b1924a812af5e356e (patch)
tree6539574210b7e22a12c43d37a1ec925a3c180d49 /dev-ruby/msgpack
parentrevbump: EAPI=5 (diff)
downloadgentoo-2-27a3158f0f92bbb34e84705b1924a812af5e356e.tar.gz
gentoo-2-27a3158f0f92bbb34e84705b1924a812af5e356e.tar.bz2
gentoo-2-27a3158f0f92bbb34e84705b1924a812af5e356e.zip
Version bump. Tests work with ruby18, but might take a long time.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/msgpack')
-rw-r--r--dev-ruby/msgpack/ChangeLog7
-rw-r--r--dev-ruby/msgpack/msgpack-0.5.5.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/msgpack/ChangeLog b/dev-ruby/msgpack/ChangeLog
index ccab7d5eabb1..27985b9b50d0 100644
--- a/dev-ruby/msgpack/ChangeLog
+++ b/dev-ruby/msgpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/msgpack
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/ChangeLog,v 1.18 2013/02/03 12:23:48 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/ChangeLog,v 1.19 2013/08/19 20:43:42 mrueg Exp $
+
+*msgpack-0.5.5 (19 Aug 2013)
+
+ 19 Aug 2013; Manuel Rüger <mrueg@gentoo.org> +msgpack-0.5.5.ebuild:
+ Version bump. Tests work with ruby18, but might take a long time.
03 Feb 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due #22900
diff --git a/dev-ruby/msgpack/msgpack-0.5.5.ebuild b/dev-ruby/msgpack/msgpack-0.5.5.ebuild
new file mode 100644
index 000000000000..75507dbec466
--- /dev/null
+++ b/dev-ruby/msgpack/msgpack-0.5.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/msgpack-0.5.5.ebuild,v 1.1 2013/08/19 20:43:42 mrueg Exp $
+
+EAPI=5
+
+# jruby → uses a binary extension
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
+HOMEPAGE="http://msgpack.sourceforge.jp/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="doc"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+each_ruby_prepare() {
+ case "${RUBY}" in
+ *ruby18)
+ # Fix tests as .clear is not available in ruby18
+ # Tests are working, but are very slow on ruby18
+ sed -i -e 's/s.clear/s.replace ""/' spec/buffer_spec.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
+}
+
+each_ruby_compile() {
+ emake -Cext/${PN}
+ cp ext/${PN}/msgpack$(get_modname) lib/${PN} || die "Unable to install msgpack library."
+}